Showing results for 
Search instead for 
Did you mean: 

MotorControl Workbench 5.Y.4 Problems

Associate III

Hi Community,

I just start desiging a AC induction motor driver with motor control workbench 5.Y.4.

But I have some problem about it. I can not generate code. I had try many ways but always same result. Its finished with "Comleted with errors" message. I am using link. I am sharing screenshot and log file.  Thanks for your all helps




ST Employee

Welcome @Mnemonic, to the community!

the motor control workbench 5.Y.4 is now obsolete and no longer supported (see available versions on the website X-CUBE-MCSDK), so please upgrade to the latest version.


In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hi Peter;

I know that but I am desiging AC induction motor driver. new version is not support custom AC induction motor solutions. So I need to use this edition

cedric H
ST Employee

Hello @Mnemonic,

Please note that the version 5 does not allow any hardware customization of the ACIM example. The only customization offered is the replacement of the motor, and this is true for both version 5 and 6, but at least in version 6 all the settings that you must not change are frozen, which is not the case of version 5.



Hi again,

But I can not create default example on it. Also its look like posible to change every setting on dashboard

cedric H
ST Employee

The two examples provided by the MCSDK are those one :


Regarding version 5, It looks like possible to change every settings, but it is not. Workbench 6 is much more reliable, and allow you to change only what can be changed.


Hi @cedric H ;

In versiyon 5 I can change MCU, current resistor, Vbus resistor, ınrush delay control and many things. But in V6 I can not change anything. Dashboard is not support those values. Is it posible to change those type of setting on code? could you share any document about this? if its not I need to use V5

Associate II

Hi @Mnemonic 

For the STM32CubeMX, try to use an upgraded version (for example 6.7.0).


Hi @Tarek_ben 

I am not sure but I was ask to local ST company this. MCWB 5.Y.4 is support maximum MX 6.6.1edition

Associate II

@Mnemonic I send you a private message.