cancel
Showing results for 
Search instead for 
Did you mean: 

STLINK-V3MODS can't work with STM32H7

DrDro
Associate III

Hallo,

until now we have used STLINK-V3SET connected with MIPI10 to custom evaluation board based on STM32H743.

For next custom board we need cost efficient debugger solution, just like STLINK-V3MODS

But it seems not to work together.

MIPI10 connector using CN5 pins 3..12 should be compatible with MIPI10 on V3SET.

V3MODS can detect correctly board voltage but nothing more.

 

Info : STLINK V3J13M4B5S1 (API v3) VID:PID 0483:3753
Info : Target voltage: 3.341772
Error: init mode failed (unable to connect to the target)

 

Pins on our board look like follw:

pinout_swd.png

Is the V3MINI or V3MOD compatible with H7 series?

3 REPLIES 3
AScha.3
Principal III

Hi,

klaro.

I have STLINK-V3MODS connected  to a H743 board - works fine (since > 1 year).

AScha3_0-1707202533686.png

I just soldered some wires to the edge connector .

Where did you connect it ?  (MIPI connector not connected on v3mods !)

 

AScha3_1-1707203305494.png

 

If you feel a post has answered your question, please click "Accept as Solution".
DrDro
Associate III

My debuger is MB1467B and looks like V3MINI but it is detected as V3MODS:

DrDro_0-1707213186882.png

Log from CubeProgrammer:

  10:52:22 : STM32CubeProgrammer API v2.14.0 | Windows-64Bits 
  10:53:18 : UR connection mode is defined with the HWrst reset mode
  10:53:18 : ST-LINK SN  : 001B00174D4B500A20373831
  10:53:18 : ST-LINK FW  : V3J13M4B5S1
  10:53:18 : Board       : STLINK-V3MODS

Bottom side of my debugger is equpiied with CN5 connector:

DrDro_1-1707213350404.png

DrDro_2-1707213485032.png

 

 


My board is as in ds , no cn5 - just the (not full) connected pads ;

cubeProg:

AScha3_0-1707214089349.png

So check : are all pins of this cn5 connected to the edge connector ?

If you feel a post has answered your question, please click "Accept as Solution".