Showing results for 
Search instead for 
Did you mean: 

NUCLEO-H743ZI2 Board ST-LinkV3 Programmer Not Working




Upon receiving my NUCLEO-H743ZI2, I was not able to access the ST-Link V3 on it. The user LEDs will not come on no matter how I change the jumpers on the board. I can only get the red com light on LD4 indicating it connected to my mac. My Cube Programmer will recognize the ST-Link, but just the Serial number and not anything else, the speed for SWD is empty. I tried to update the ST-Link and it fails halfway through the update. I tried changing all the jumpers around to see if anything happens but no luck so far. Has anyone else had this issue before? I don't know how to reset everything to factory settings to retry downloading the software again. Thanks.

ST Employee

Hello @afatica and welcome to the ST COMMUNITY 😊.

I suggest you to configure the board jumpers and connect it to the PC as indicated in the Getting started of the UM2407. Then using the STM32CubeProgrammer, perform a firmware update. After that, try to connect the board using normal mode and if it did not work try the connection under reset. If that doesn't work, please add more details about your issue.

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.