Showing results for 
Search instead for 
Did you mean: 

Cannot get stm32 nucleo board to work again after system format

Associate III

I am using stm32L496zg nucleo board. It got started and worked well. But after I formatted my system, the latop does not recognize it; USB Device not recognized. The last USB device you connected to this computer malfunctioned. Windows does not recognize it. I tried installing drivers of st link again, but still its not recognized. 




Can anyone plz advice me, whether the board's working or it can be resolved with drivers? 
Thanks in advance


Chief II

But after I formatted my system

what did you format exactly ?

If you feel a post has answered your question, please click "Accept as Solution".

The laptop I mean. But I checked the stm nucleo board on another laptop too, but same response, USB device not recognized.

try other cables...


check power supply on board ( i see no power led ...LD6 green )


If you feel a post has answered your question, please click "Accept as Solution".

Have you reinstall to laptop STM32CubeProgrammer sw?

ST Employee

Hello @KMINH.1 ,

Could you please check Jumpers, for that I advise you to refer to UM2179 and precisely section 5.4 Embedded ST-LINK/V2-1.

May this FAQ How to solve debugger connection issues - STMicroelectronics Community will help you.

Thank you.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Power is ok at input, but does not appear at any of the power supply points. 
Also, reinstalled st link v2 program as well as programmer.
Will try to disconnect embedded st link(thru jumpers) & and connect external st link v2 usb .

it's normal that no power on the board if STLINKV2 is not work well. As a power switch controlled by STLINKV2 embedded if OFF by default. if your board is not work also with another PC (it should work well before with STLINKV2?), I suggest you to upgrade STLINKV2 FW and try again.  

Hi @QSHAO.1 , 

 I tested the stm board with external st link v2 USB dongle (by disconnecting jumpers at CN4), the stm32 board seems to be working fine. The problem lies in in-built ST Link programmer. But the ST Link utility software fails to detect. It can be detected by device manager.
   As you said, how can I upgrade st link firmware , when its not at all detected? Plz suggest.

Pavel A.
Evangelist III

@KMINH.1 What exactly shows the device manager? You don't need to upgrade the firmware.