Showing results for 
Search instead for 
Did you mean: 

Port SPN3 motor-control examples to DK2?

Associate II

We are considering using a combination of the stm32mp157 and several powerSTEP01 devices in a system with multiple stepper-motors.

The X-NUCLEO-IHM03A1 plugs into the -DK2 just fine, but the SPN3 examples only work on the F0xx, F3xx, F4xx, and L0xx series.

Attempts to port one of the examples to the stm32mp157C-DK2 have not worked.

  1. Where can we get information on porting one platform's (e.g. F4xx) "arduino-style" connector to the stm32mp157C-DK2 "arduino-style" connector?
  2. Has anyone ported other code from the F0/F3/F4/L0 that uses the "arduino-style" connector onto the connector on the stm32mp157C-DK2?
    1. If so, can the code be shared, or the process documented?

We are approaching the GO/NOGO point of using the stm32mp1 and the powerSTEP01. Time is critical on this.

Senior II

Well... I found that "quick and dirty"-Try, i did a couple of months ago. Main purpose was to learn about FreeRTOS and to get my Hardware working with CubeIDE, MX and TouchGFX... (Let´s say it was just a proof of concept xD) There´s also some code for a plc01a1 board inside, which isn´t usable for anybody, because i use a special adapter to "bend" some Arduino pins just for that board to solve pin conflicts with ihm03a1 😉 I´m sorry, but also forget about a lot of old comments in code and the "style". I´m not an engineer and as i said: it was just "quick and dirty" 😉

maybe it´ll help a bit …

ST Employee

Hi @karlchansen​ 

Please pay attention that using MP1 in Production mode the resource management is perform on Linux side.

Refer to :

In order to put this aside for a first step and ease the debug, I recommend you to mature the coproc firmware using the engineering boot mode.

Please refer to :

Hope it help,


In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.
Associate II

Thanks for the file. I have been firefighting another project and am just now getting back to this one. I'll be taking a look at it this weekend.

I have also been dabbling in arduino on the M4-side of the stm32mp1. It looks like @Bumsik Kim​ has put a lot of work into getting the arduino core working on the stm32mp1, and the company megunolink ( has created an arduino library for the powerSTEP01. I am hoping the combination works and will make my tests much simpler.