Showing results for 
Search instead for 
Did you mean: 

STM32CubeProgrammer 2.3.0 released

ST Employee

Dear community

We are pleased to announce the release of STM32CubeProgrammer 2.3.0

New features

• Added the support of the STM32L4Pxxx and STM32L4Qxxx microcontrollers

• Added the support of the STM32H7Axxx and STM32H7Bxxx microcontrollers

• Added the beta support of the STM32WL Series microcontrollers

• Added the official support of the STM32L5 Series microcontrollers

• Added the support of HSM V1 SFI/SFIx for STM32H7Axxx microcontrollers

• Added the support of HSM V1 SFI/SFIx for STM32L5 Series microcontrollers

Fixed issues

63887 STM32CubeProgrammer does not program Option Byte from an .hex file for STM32F446xx.

64229 STM32Cubeprogrammer does not erase sector 128 and upper on STM32L476RG.

66609 STM32CubeProgrammer programming request of OTP byte via STM32CubeProgrammer.

67025 STM32Cubeprogrammer cannot connect ST-LINK without the mass storage feature. 77015 Support Flash Loader for STM32F769-EVAL:MT25QL512.

Known problems and limitations

• For the STM32L5 Series, the connection via the ST-LINK protocol is allowed only when mode is set to hotplug with TZEN=1.

• For the STM32L5 Series, the Option Byte programming GUI is not intuitive enough. Refer to the STM32L552xx and STM32L562xx advanced Arm®-based 32-bit MCUs reference manual (RM0438) for permitted accesses.

• For STM32L4Pxxx and STM32L4Qxxx devices, Option Byte programming via bootloader interfaces presents some limitations.

• For STM32H7Axxx and STM32H7Bxxx devices, Option Byte programming via bootloader interfaces (USB) presents some limitations.

• STM32L5 series programming presents limitation in macOS® when TZEN=1 and RDP=0x55.

• With some small-screen resolutions, the graphical interface of STM32CubeProgrammer presents anomalies such as inaccessible buttons.

• Display issues depending on the monitor used can occur with Linux®.

Get the new version now

Uwe Bonnes
Principal III

I still miss an option to reset all option bytes to factory default. Please consider such an option!

Associate II

Any idea when this horrible path bug will be fixed? It should take less than 20 minutes to fix it.



Senior III

I would like to ask for improvements in the external loader handling:

  • Why can't we read more than 1M bytes from an external memory chip ? I don't understand from where the limitation comes from ?
  • The board name is cleverly extracted from the device name. I would like to have the memory chip name extracted as well as it would ease the readability of the available external loaders table.

Best regards,


Associate II
  1. Support for SWV should be added to CubeProgrammer!
  2. Remote IP address should be added for shared ST-LINK connection over TCP.
  3. st-link_gdbserver should be integrated with CubeProgrammer.
Associate II

I have installed the latest (en.stm32cubeprog_v2-3-0) version in Windows 10 64 bit PC.

After installation, the first startup icon with spinner only comes up , closes and does not run.

As far as googled and found online, it is java versioning issue. This is not new. Last version also, I had to manually kill the Java process from Task Manager, and then re-opening used to run.

Now, I don't see a Java process itself.

Given there are variety of Java versions, environments, when will you fix your CubeProgrammer dependency path settings, so that it looks at correct place !?

Java versions in my PC are:

C:\Program Files\Java>dir
 Directory of C:\Program Files\Java
27/01/2020 10:29   <DIR>         .
27/01/2020 10:29   <DIR>         ..
05/07/2018 14:17   <DIR>         jdk-10.0.1
22/10/2018 08:19   <DIR>         jdk-11.0.1
27/08/2019 09:02   <DIR>         jdk-11.0.4
27/08/2019 08:59   <DIR>         jdk-12.0.2
14/11/2018 09:43   <DIR>         jdk1.8.0_192
27/08/2019 09:00   <DIR>         jdk1.8.0_221
27/01/2020 10:29   <DIR>         jre1.8.0_231
27/01/2020 10:29   <DIR>         jre1.8.0_241

C:\Program Files (x86)\Java>dir
 Directory of C:\Program Files (x86)\Java
27/01/2020  10:29    <DIR>          .
27/01/2020  10:29    <DIR>          ..
27/08/2019  09:01    <DIR>          jdk1.8.0_221
27/01/2020  10:29    <DIR>          jre1.8.0_241

And then environment

C:\Program Files\Java>set
Path=C:\Program Files (x86)\Common Files\Oracle\Java\javapath; .... 

Would you please fix this silly "basic" issue ??

Agreed !

Using JAVA_HOME (or javapath, idk) would be better, especially since the Java directory is (for now) also used by the uninstaller of the product. In my case, I like to keep only the latest revision of Java on my machine. So I was not able to remove STCubeProg because it could not find an old version of java. Renaming the java directory to match the version needed by the uninstaller solved it.

Does anyone know if any of the OpenJDK versions work for stm32cubeprog v2.3.0? I am currently trying different ones. doesn't work.

Associate II

I am just disappointed, tried and tried with many java versions and nothing works. Is there a simple "how to" or things to check? I am using a MAC and I can tell it has being ONLY PROBLEMS. On Windows it works. Pretty Please.

Infact, the document "en.DM00441049.pdf" - STM32CubeProgrammer release note (RN0109) and UM2237 User manual for STM32CubeProgrammer en.DM00403500.pdf both mentions of Host PC System requirements for Java as …

The Java™ SE Run Time Environment 1.8 must be installed. Only Java8 is supported.

The Java™ SE Run Time Environment 1.8 (version 1.8.0_121 or newer) must be installed by Oracle® (Only Java™ 8 is supported).

If OpenJDK is used, be sure to download and install the OpenJFx library.

After Oracle® announcement related to the “End of Public Updates for Oracle JDK 8�?, access to OpenJDK is possible via

The minimal supported screen resolution is 1024x768.

But, even with the specified requirements in these 2 notes, none of them works !

Hopefully next time STMicro engineers develop and test properly before release !?