Showing results for 
Search instead for 
Did you mean: 

Target Software Startup Script Error

Utkarash Patil
Associate III

Hello All,

I am using STM32F777IITx MCU based custom board with STM32CubeMx v4.24.

I want to built a application where i want to Read/Write data from/to flash.

I am have written a small application where i write 10 bytes of data to flash and also read those 10 bytes from flash

My code Complies properly with no errors, However, when i tried to run the code in Debug mode i am getting the error mentioned below.


Whereas i have not changed anything in the Startup script, also i have attached the startup script below

# Set flash parallelism mode to 32, 16, or 8 bit when using STM32 F2/F4 microcontrollers
# 2=32 bit, 1=16 bit and 0=8 bit parallelism mode
monitor flash set_parallelism_mode 2
# Load the program executable
# Enable Debug connection in low power modes (DBGMCU->CR)
set *0xE0042004 = (*0xE0042004) | 0x7
# Set a breakpoint at main().
tbreak main
# Run to the breakpoint.

So please help me to get rid of this issue at the earliest and if i am making any mistake while debugging please help me with it ,

Also if there are changes to be made in startup script please help me with correct startup script

Thanks and Regards


Pavel A.
Evangelist III

Have you tried to change set_parallelism_mode to 1?


Hello Pavel,

Thank you for the response,

I Changed the parallelism mode to 1 and tried to debug however still facing the same issue with same error pop-up as mentioned in last post.

I have attached the screen shot of startup Script please check.


Please help with this earliest.

Thanks and Regards


Utkarash Patil
Associate III

Hello All,

Are there any updates regrading this isssue,

I request you to Please help at the earliest as i need the solution on the urgent bases

thanks and regrads


It looks like some error occurs in the "load" command.

Please open the Debugger console window and see what it says there.

(the output should begin with "STMicroelectronics ST-LINK GDB server" .... )

-- pa

Hello Pavel,

Thank you for the Response,

I have attached the error message on the console, however i am not getting anything like "the output should begin with "STMicroelectronics ST-LINK GDB server....." .



Error: Connection to target must be established before performing the write command.

Encountered Error when opening /opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.2.0/Servers/STM32CubeProgrammer/bin/STM32_Programmer_CLI

Error in STM32CubeProgrammer

Debugger connection lost.

Shutting down...

Please check the error and help at the earliest its urgent

Thanks and response


Associate II

Hi Utkarsh,

Is your error is resolved because i am also facing same error.

Please help at the earliest. i need it urgent

Thanks in Advance.




Hi Sai and Utkarsh,

Did you find a solution to the above issue, I am also facing the same error.

Please help at the earliest.