cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeMX 6.10.0 released

Semer CHERNI
ST Employee

 

We are pleased to announce you that the official release of STM32CubeMX V6.10.0 is available.

  • What is new in STM32CubeMX V6.10.0?
    • Added the support for STM32CubeMP13: bare-metal firmware for the STM32MP13xx microprocessors.
    • Added the support for new microcontrollers in the STM32WBA series
    • Added the support for new boards based on the STM32U5 series and STM32WBA series
    • Added the support of the memory management tool for the STM32WB series and STM32WBA series
    • Added the possibility to install STM32CubeMX without administration rights
    • Added the Start From Board new feature
  • Main fixed issues:
    • 130929  Enable access to LSI/LSE by enabling an access to backup domain to configure them.
    • 158979 [Boot path configuration] [Secure manager: Wrong location of RAM in linker file for secure manager.
    • 158982 [Boot path configuration] [Secure manager] Missing secure manager API files in STM32CubeIDE generation
    • 159253 Bad number of Sink or Source PDO generated by STM32CubeMX in usbpd_pdo_defs.h.
  • Known issues fixed and problems and limitations:
    • Please refer to the release note.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

15 REPLIES 15
Piranha
Chief II

Had an installation of CubeMX v6.9.2 on Windows 7 without any logins and upgraded it to v6.10.0 with "Install for all users". After the installation, this stayed open and neither the X (Close), nor the Cancel worked - those just do nothing. For Cancel even the hoovering doesn't work - none of the button colors changes.

Piranha_1-1701548078258.png

Now for the CubeMX itself. None of these work at all - again clicking just does nothing:

  • Help => Check for Updates
  • Help => Manage embedded software packages
  • myST => Login
  • Opening IOC files, which were saved by a previous versions, any way from a CubeMX GUI.

Opening IOC files, which were saved by a previous versions, by a double-click in Windows Explorer leads to this:

Piranha_0-1701546950370.png

Running it with "Run as administrator" - the same result. Installed "for me only" - the same. Uninstalled it, removed all of it's files, installed v6.10.0 fresh - still the same result.

A fantastically "enjoyable cohesive experience"!

Thanks for warning, i for this many years use two computers, one only for test "NEW" St versions.

Seems every third is relativ ok.?!

Piranha
Chief II

I'm basically using CubeMX only for finding out pin layout combinations and some minor features, therefore I do not depend on it in any significant way. I can just install an older version. For now I'm returning to the v6.8.1 before the "enjoyable cohesive experience" was implemented.

One blind guess is that they updated the integrated JxBrowser to a version based on a Chromium version beyond v109, which requires at least Windows 10:

https://jxbrowser-support.teamdev.com/release-notes/2023/v7-30-3.html

Oskar_H
Senior

Wait a second... They have upgraded to the latest JxBrowser just to be able to continue login for downloading packs ?

Is that the real reason for ending the support of Windows 7 ? Seriously...

I am not concerned, but poor customers who will have to upgrade their OS, and potentially their obsolete PC just because of that *** feature.

Piranha
Chief II

The fact, that the whole home screen is blank in my screenshot, suggests it could also be a web page, though a local one. I guess showing the 6 marketing/info images on the lower right corner was too hard for them to implement in Java...

But those are just my educated guesses.

Not easy to know how the home page has been written... Unless by doing reverse-engineering of jar files ? Yes, but which of them ?

By the way, it is true that the installer of STM32CubeMX has been changed in 6.10.0: now it asks for private or shared installation, which gets rid of the administration rights if you choose the first one.

But unfortunately it is only available for Windows OS !

Does anyone know if this will be supported for other OSes soon ?

The "private" installations are abusing the historically flawed default Windows configuration for file access and execution rights. Microsoft should have removed the rights for the basic User to run executables outside of the protected directories and leave the Power User group. Instead they effectively removed the Power User group and didn't fix the terrible security holes for a basic User group.

Other OSes do not have this nonsense and therefore by default one needs to have a rights assigned by the administrator.

kroko
Associate

In STM32CubeMX 6.10.0 it is impossible to use sliders in order to filter out USB2.0 FS capable MCUs.

See screenshot.
- STM32F070RB has USB 2.0 FS
- there is no way to use filters (sliders) to pick out USB FS devices as all USB related numeric data fields for this MCU equals 0
-  only option to get USB FS MCUs at a glance is to enable USB column and sort by that

Screenshot 2023-12-20 at 19.47.04.png

 

######
Senior

When trying to update Cube MX as per instructions at top of thread, I get through the download installation screen. All running as Admin. 

MXUpdate.png

It prompts me to restart. I restart, running as Administrator and I get the following message with the update failing.

MXUpdate Error.png

Pressing Retry doesn't work. Can anyone from ST please advise?