cancel
Showing results for 
Search instead for 
Did you mean: 

ThreadX thread and queue names not displayed properly in CubeIDE 1.15.0 debugger (STM32H5)

New workspace

New STM32 project 

Board Selector Nucleo-144 STM32H5 NUCLEO-H563ZI

Take the defaults

Set the tick to TIM6

Pinout & Configuration - Middleware and Software Packs - THREADX

Generate App Init Code - check

Save everything, compile, debug, put a breakpoint on the opening curly in tx_app_thread_entry (app_threadx.c).

Run and reach the breakpoint.

Window - Show View - ThreadX - ThreadX Thread List

Notice how the names are just the first character of the name strings.

This happens on queues as well. I suspect semaphores and mutexs will be the same.

This worked properly in a previous version of CubeIDE on STM32L4 if that matters.

Full cube project attached.

2 REPLIES 2
Sarra.S
ST Employee

Hello @Andrei Chichak,

Thank you for your valuable inputs

I created an internal ticket to track the issue ( Internal ticket number: 178581)   

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Yes, I checked a previous project, using a L452 processor, that had the proper names previously and it is now broken.

Also, the names of semaphores, byte pools, message queues, mutexes, event flags, and threads are all truncated.

So, it looks like it is an issue with 1.15.0.

 

Andrei