Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE not finding ST-Link



  I have been using Atollic TrueStudio for a good while and now upgraded to STM32CubeIDE. I have both on my machine, and the Atollic still sees my ST-Link, but STM32CubeIDE doesnt.  One thing I noticed that Atollic just had "ST-Link" from the drop down "Debug Probe" selection.  The IDE has ST-LINK (ST-LINK GDB Server) and ST-LINK (OpenOCD) , what is the difference? I have tried the both and get the below message.  The STM32Cube Programmer works too, so this is really strange. Anyone let me know what I am doing wrong?  I have the small ST-Link V2 adapter.

No ST-Link Detected !! Please connect ST-Link and restart debug session.


Many Thanks




probably you have a "clone" F103 in your stlinkV2 stick, most times a CKS32F103.

STM now fighting against clones, so IDE refuses to work with these.

to proof , install CubeProgrammer , try to use your stlink - it should work , can program cpus also.

but in IDE the stlinkV2 needs to have genuine STM32F103 inside to work.

If you feel a post has answered your question, please click "Accept as Solution".


  I can connect with CubeProgrammer , and ST-Link utility. So sounds like I will have to get a genuine st-link



Read, what I wrote.

Only IDE check for clones, up to now.

So you have a clone.

Ed. Don't know, what's your last post. This forum software is pita. Forget it.


If you feel a post has answered your question, please click "Accept as Solution".
Pavel A.
Evangelist III

Also, make sure that only one program (CubeIDE/Atollic/CubeProgrammer/... ) connects to the ST-LINK at any moment. Other programs won't see a ST-LINK while it is in use.

ST Employee

Some hints to recognize a genuine ST-Link V2.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.