Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE - an all-in-one multi-OS development tool

I couldn't find any discussions here about this newly released tool, so I'm creating one.

Here is the link - STM32CubeIDE

Associate II

I am attempting to run STM32CubeIde on a 2017 Macbook Pro (MacBookPro14,1, P/N: A1708-3164) running MacOs 10.14.4 (Mojave) and am having an issue where the program seems to get stuck "Checking for Updated Files ...". The IDE launches and shows the initial page, but when I click on the "Start new STM32 project" button the "Initializing STM32 Target Selector..." and "Checking for Updated Files .." pop-up appear and never seem to finish.... Is anyone else seeing this? I have un-installed and re-installed the IDE with no change in behavior.

I am not sure why, but unchecking the "STM32CubeIde" line from the Available Software Sites in Preferences appears to have resolved this.

If this is something you are missing then I am missing it as well.

The even stranger thing is that it doesn't happen to every chip family in my tests.

I've gone ahead and created a ticket for this.

I'm really not that experienced with TouchGFX.

It looks like some symbols that should possibly be included is not?

Do you have a step-by-step on how to recreate the problem?

I tried creating a TouchGFX project with CubeIDE but it looks like I need an executable, so I need standalone TouchGFX as well?

Thanks Markus!

I tested further and found that if I hand-edit the .ioc file and change the rev from 1.14.0 to 1.13.0, then it will use the older package.

I should mention that the entire reason I've gone down this path is because I had actually modified the contents of 1.13.0 to include the multi-UART CDC enhancements that I created. So in CubeMX, I copied 1.13.0 to and made my changes there. Then, I was able to tell CubeMX to use my modified package in the repo to build with my changes. It appears this is no longer possible in CubeIDE. It doesn't recognize my modified repo as valid. And even if I ZIP that modified package dir and try to install it using the "From Local..." option in Manage Embedded Software Packages, it fails with the message "This package version is not managed on this version of STM32CubeMX".

I really hope that the ability to point to a specific package directory and use it has not been eliminated! I definintely need a way to override to standard package code and share it across multiple projects and with multiple other users.


fedora 30, cube ide is not run properly. i' m not creat new project, when tried in cubemx section, just blank screen.

Apparently all linux packages are built for the amd64 architecture, is this correct? I can' t install the Debian package in my i386 PC.


Do we have another mirrors link to download the STM32CubeIDE? Gosh, the website is terribly slow!