Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE 1.15.1 Not Generating Code

Associate II

I have an STM32G474 project that has been working for some time but the latest update doesn't generate code from the .ioc config GUI.

If I make I make changes in the editor and select generate code, the pop flashes quickly and goes away but no code gets generated. I've tried this on a couple of Windows computers with the same result. 

Associate II

I got it to work by starting a new project with the same processor. That gave me an error message that I didn't have the right firmware and needed to login and download. The requirement to be logged in is absolutely infuriating BTW.

After getting logged in and having the firmware download, the code would generate. But with an existing project, there was no error message that something was wrong. It would just pop up a window and close it without reporting any problem.

ST Employee

Hello @DamageG  and welcome to the community,

Could you please check the connection and login to "myST" account to download the firmware and automatically generate the project

Hope this helps!