cancel
Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE 1.13.0 released

Semer CHERNI
ST Employee

STM32CubeIDE 1.13.0 was released today on st.com as well as an in-tool update patch.

  • What is new in 1.13.0?
    • Added the support for new microcontrollers in the STM32U5 series
    • Added the support for new microcontrollers in the STM32WBA series
    • Added the support for two new boards related to the STM32U5 series: STM32U5G9J-DK1 and STM32U5G9J-DK2
    • Added the support for one new board related to the STM32L4+ series: STEVAL-SMARTAG2
    • Added the user authentication interface to permit package download
    • Updated to Eclipse® 2023-03
    • Updated to GCC 11 support by default
    • Added CMake project support
  • Updated debug:
    • Changed values highlighted in yellow in the SFRs view
    • Debug authentication for STM32H5 products
    • Support for programming using multiple external loaders with OpenOCD
  • Updated for microprocessors:
    • Support for the latest release 5.0.0 of OpenSTLinux
    • Addition of the TCP console for semihosting output
  • Main fixed issues
    • 109036 [UC5-REGENERATE][CubeIDE][Examples]Build failed when changing some configurations of LoRaWAN_End_Node example
    • 131635 Add option to highlight when a live variable changes its value
    • 143369 STM32CubeMX Linker script generation problem
  • Known issues fixed and problems and limitations
    • Please refer to the wiki.
  • Where do I obtain STM32CubeIDE 1.13.0?

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

12 REPLIES 12
JTP1
Lead

Hello

This latest version 1.13.0 seems to give error to sysmem.c like this:

JTP1_1-1689098566183.png

CubeIDE 1.12.0 compiles the same project without any problem.

Projects are generated from TouchGFX template (4.21.4 or 4.22.0) and then imported and compiled in CubeIDE. I know that this can be fixed by changing caddr_t to void or including <sys/types.h> to sysmem.c

But what is the reason for this different behavior in CubeIDE 1.12.0 and 1.13.0 , new GCC version ? I'm afraid this will cause more issues to people how is trying to study TGFX.

br. J.T

 

 

Hello @JTP1 

Yes indeed the GCC version was upgraded from GCC10 to GCC11 with the STM32CubeIDE 1.13.0.

You are right with the solution you have proposed of changing the caddr_t to void* or include the <sys/types.h> to sysmem.c.

With this been said, I will raise the issue internally to review it and provide a permanent solution.

KR,

Semer.

To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

The same here.

i fixed it by replaceing caddr_t with void* 

caddr_t seems to be outdated. 

Werner 

padawan
Senior

ID 

139768After programming a device CubeIDE opens every time a new tab with startup file and give focus on that tab.

is not fixed!

 

The new tab will also be opened when entering and leaving the debug mode!

So after "Debug" you have 2 more tabs open!

Please take a look at:

https://community.st.com/t5/embedded-software-mcus/error-after-calling-printf/td-p/574044

I've restored back to 1.12.1 to continue working.

a_a
Associate

I have noticed that the new release starts loading the macOS too much. I have at least 50% CPU load by Chrome Helper GPU (and render the process as well) that runs CubeIDE. I reinstalled ide with a fresh installation and got the same result.

PHolt.1
Senior II

The GCC v11 tools (Cube v1.13) break a few things.

One is the has no explicit encoding set warning mentioned here
https://community.st.com/t5/stm32cubeide-mcu/has-no-explicit-encoding-set-warning/td-p/574835
Despite extensive googling I cannot find a fix for it. The various fixes for eclipse do not work, and neither does the one under project / properties / resource

PHolt1_0-1689538045194.png

 

Another is detailed here
https://www.eevblog.com/forum/programming/stm32f4-gcc-v12-to-v13-some-weird-error-messages/

I think some compiler checking options have changed.

 

PHolt.1
Senior II

This has been fixed - see eevblog link above.

 

JojoS
Associate III

After upgrading from 1.12 to 1.13, the debugger stops suddenly after hitting a breakpoint. Also stops after a few steps. The debugger console does not show exceptions.

edit:
I've reverted now also to 1.12.1, 1.13.0 is unusable for me. The debugger stops with nothing more than 'client has disconnected', same code with 1.12 no problem. I had cleaned and rebuild the project.
After rebuilding, 1.13 pops up an error, but build is ok.

build-fehler.jpg

1.13 adds some template code that produces duplicate symbols. It also adds MPU_initialize which produces unused warning.
Such simple things are not discovered by testing a new release?