Showing results for 
Search instead for 
Did you mean: 

Error trying to launch STM32CubeIDE on linux!

Associate III

I have installed the STM32CubeIDE 1.12.0 from the STM32 official website onto my Arch Linux laptop but when i try to launch it, it closes and reports an error after the splash screen.

I have searched on pacman (the arch package manager) for stm32cubeide too, but they are having the same error too. See the comments section on

Here is the error:

[ri@r Desktop]$ /opt/st/stm32cubeide_1.12.0/stm32cubeide_wayland
SWT WebKitGDBus: error creating DBus server Error binding to address (GUnixSocketAddress): No such file or directory
SWT WebKit: error initializing DBus server, dBusServer == 0
(STM32CubeIDE:9473): GLib-GIO-CRITICAL **: 16:40:15.499: g_dbus_server_get_client_address: assertion 'G_IS_DBUS_SERVER (server)' failed
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fd88683ed16, pid=9473, tid=9474
# JRE version: OpenJDK Runtime Environment Temurin-11.0.17+8 (11.0.17+8) (build 11.0.17+8)
# Java VM: OpenJDK 64-Bit Server VM Temurin-11.0.17+8 (11.0.17+8, mixed mode, tiered, compressed oops, g1 gc, linux-amd64)
# Problematic frame:
# C  []  Java_org_eclipse_swt_internal_C_strlen+0xf
# Core dump will be written. Default location: Core dumps may be processed with "/usr/lib/systemd/systemd-coredump %P %u %g %s %t %c %h" (or dumping to /home/richard/Desktop/core.9473)
# An error report file with more information is saved as:
# /home/r/Desktop/hs_err_pid9473.log
Compiled method (nm)    9481 5616     n 0       org.eclipse.swt.internal.C::strlen (native)
 total in heap  [0x00007fd917d3c190,0x00007fd917d3c530] = 928
 relocation     [0x00007fd917d3c308,0x00007fd917d3c338] = 48
 main code      [0x00007fd917d3c340,0x00007fd917d3c528] = 488
 oops           [0x00007fd917d3c528,0x00007fd917d3c530] = 8
Compiled method (nm)    9486 5616     n 0       org.eclipse.swt.internal.C::strlen (native)
 total in heap  [0x00007fd917d3c190,0x00007fd917d3c530] = 928
 relocation     [0x00007fd917d3c308,0x00007fd917d3c338] = 48
 main code      [0x00007fd917d3c340,0x00007fd917d3c528] = 488
 oops           [0x00007fd917d3c528,0x00007fd917d3c530] = 8
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

And the error report file is attached below.

Associate II

Update from me on my Arch system:

Installing webkitgtk-6.0 ( fixed the issue for me.

Associate II

Installing the webkitgtk-6.0 package solved this issue for me on Arch.

The flatpak worked for Manjaro on my PC. None of the other work-arounds did.

I did it - but same problem, always crashes with the same error

Tumbleweed is too up-to-date for CubeIDE...

Waiting the next release and back on Windows :(

Or, much easier, switch back to STM32CubeIDE 1.11.x and everything will be ok.

Or, even better than that, toss that Eclipse-based STM32CubeIDE out the window, and use STM32CubeMX to generate code for use with Visual Studio Code or any IDE of your choosing.


Having the identical error on Fedora 38 using both the generic install and the RPM. I have  webkit2gtk4.1 installed and get the same dump

Have it installed, does not work for me. Ubunutu Lunar 23.04

Associate II

Update on this (with some solutions i found in the AUR comments / forum):

The issue is indeed in an incompatibility in webkit2gtk and eclipse. In an earlier post i said that installing webkitgtk-6.0 solved the issue, seems like it didn't.

But i have found a new solution which is removing webkit2gtk from your system (has to be done with pacman -Rdd otherwise cubeide will be removed as well). This breaks browser functionality in eclipse (which i don't really know what its supposed to be and have probably never used, so yea i'm fine with that). Someone else mentioned swapping webkit2gtk for chromium, which i guess could work, but i didn't bother trying. If you're interested in this you can probably find the comment (which also contained a link) in the comments of the AUR package.



I want to start working with STM32WB55 micros.

Some time ago, with much trial-and-error, I installed STM32CubeIDE V1.8.0 on to my Suse-tumbleweed computer. It mostly works well (ask me for details if you want to know more). This installation type DOES NOT allow updates.

I downloaded STMCubeIDE V1.12.1 (generic linux), and installed it the same manner as above. It installs without complaining. But it does NOT run - it seems to start okay, prompts me for the "workspace", but shortly after java dies...

My java version is:-

openjdk 17.0.7 2023-04-18

OpenJDK Runtime Environment (build 17.0.7+0-suse-1.1-x8664)

OpenJDK 64-Bit Server VM (build 17.0.7+0-suse-1.1-x8664, mixed mode, sharing)

My STM32CubeIDE V1.8.0 still works as it did.

Can anyone help me?

Thanking you


AI = Artificial Intelligence, NI = No Intelligence, RI = Real Intelligence.