Showing results for 
Search instead for 
Did you mean: 

Could not debug the OpenAMP_TTY_echo

Associate II


I am following the tutorial of developing on M4 with the STM32MP1 but when I do the

"debug as" to this project, it comes out an error.


The STM32MP1 has connected to my PC through the STLINK usb; the boot0 and boot2 on the board have been set to "on"; and no another Console view.

I could not find out the problem.

Any suggestion would be a great help.



ST Employee

Please have a look in

If you have set boot0 and boot2 to ON this mean 'production mode' (Boot from SD cars and debugging with Linux) and so you need to use (in addition to STLINK) another USB or Ethernet connection to PC to allow the debugger to load the FW to the target prior to debug it using JTAG/SWD.

  • Engineering Mode, with Cortex®-M firmware download via JTAG/SWD
  • Production Mode, with Cortex®-M firmware download :
    • via Ethernet Link to the LAN or Point-to-Point
    • via Ethernet-over-USB for point-to-point connection

Alternatively, to use Engineering mode (i.e. debugging Cortex-M4 FW alone) you need to use boot0=OFF and boot2=ON. Note that in that case, your FW need to make all initialization usually devoted to Linux (i.e. clock and some other init).

In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.

Thank you for the answer, Patrick. I added an Ethernet cable (connecting my PC and the development board, could not connect to the LAN for some reasons) as you said in the production mode. But I still got the same error.