Showing results for 
Search instead for 
Did you mean: 

Interference between RTC and LoRa activities in the NUCLEO STM32WLJC1 board

Associate III

Hello guys, I have this situation where when I use the LoRa protocol in my application, the RTC stops working and vice-versa. Anyone have an idea of what could be causing it and the solution for the problem?


At the configuration level I'd suggest dumping the RCC registers, looking especially at clocks for pins/peripherals, and RTC / BKP unit. Compare and contrast what's enabled and working, and what's not in the two cases.

The LoRa shouldn't interfere with the RTC operation as it just needs SPI and GPIO (DIO) related connectivity. You could check if the RTC is being used for timing.

For the ADC / DEBUG interaction you're going to need to be a lot more specific about what pins are involved, and the setup, for anyone to address issues remotely.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Yes, I think that probably the RTC is being used as a timer. For the LoRa to work, the RTC is in free running binary mode, but the problem occurs when I switch to BCD calendar mode, that makes the LoRa stops.

Also, the RTC and RCC has this warning, that I'm not sure if interfeers:

FPicc1_1-1700601918416.png FPicc1_2-1700601959349.png

The ADC issue might be that I'm using the PA13 and PA14 as a ADC, but I didn't test it without them yet, but in the picture there is all the ports I'm using


Consider that the base code is the Ping-Pong LoRa example from ST.

ST Employee

Hello @FPicc.1 

The Ping-Pong application use the RTC on Free running binary mode. If you are looking to use the Free running BCD calendar mode, I suggest you use the mixed mode (free running BCD calendar and binary mode). 

Best Regards.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

Hello @STTwo-32 , thanks for your reply.

I actually tried to use the mixed mode but was still getting interference in the applications. Do I have to do some other adjustments to make it work (like transform the date type or something like that), or it was supposed to work like this already?