Showing results for 
Search instead for 
Did you mean: 

CubeIDE keeps generating error????

Senior III


I have an STM32WB55 pcb that I developed.  I have been working with it for over a month now and all was working fine.  Today the CubeIDE decided to generate an error (see below):

Download verified successfully

Failed to assign value 80037b1, to register 0
Failed to assign value 2002fff8, to register 0
Failed to assign value 8001390, to register 0
Shutting down...

I have an STLINK-V3SET plugged directly into a Windows 11 machine (no hub).  I have tried a second board which also worked fine and it too is generating the message.  I have closed the IDE, unplugged power from the board and powered down the debugger THEN repowered all, cleaned the project and rebuilt and SOMETIMES it works and SOMETIMES it doesn't.  I have been working with this debugger and STM32 products for a while and have not seen this before.  Can someone please tell me what to do as we are under urgent development at this end!

The application used to go to main() but now when it breaks it hangs at the line below:


  ldr   r0, =_estack

Thank you