Showing results for 
Search instead for 
Did you mean: 

X-CUBE-TOUCHGFX 4.17.0 is out

ST Employee

Hi Everyone,

If you haven't noticed by now, X-CUBE-TOUCHGFX 4.17.0 is out, available from STM32CubeMX 6.0+ and from as a zip (Also installable through STM32CubeMX).

Here is the documentation for 4.17.0:

Main features:

  1. Complete redesign of the TouchGFX Designer
  2. Dual core support of TouchGFX Generator
  3. FMC interface support of TouchGFX Generator
  4. Various minor framework improvements like font handling

You can see all the bug fixing and improvements in the changelog.


If you wish to use L8 images in 16-,24- or 32bpp configurations, for some RTOS you will need to remove the OSWrappers::taskYield() function call in the DMA2D file templates of the X-CUBE installation (FreeRTOS from CubeMX works OK):

  • Navigate to your Users/<user name>/STM32Cube/Repository/Packs/STMicroelectronics/X-CUBE-TOUCHGFX/4.17.0/CubeMX/templates/Target folder
  • Depending on your bit depth open the dma_XXbpp_implementation_tmp.ftl file (16. 24 and 32 bpp)
  • Delete (or comment) the OSWrappers::taskYield() call in the while ((READ_REG(DMA2D->FGPFCCR) & DMA2D_FGPFCCR_START) != 0U) loop
    // OSWrappers::taskYield();
  • Regenerate code from STM32CubeMX for your project


Senior II

TouchGFX 4.17 UI is WORSE than 4.16.

  1. Poor contrast in dark theme text/background makes impossible to see texts, I must use light theme
  2. Selecting elements from a small laggy dropdown menu is way more annoying than before, when you could see them all at side.

Why are you spending 6 months to make the product worse for no reason? You now completely disregard all problems in forums.

1-2 years ago this project was promising (good features, quick support), but you have obviously changed your management to something awful (+1 month support time, not improving product).

Hi Jonathon,

Sorry for the late reply I have been busy with work.

Cheers for the thread link, it was definitely a pathing issue, I was looking at in the MCU GCC Linker and had the Windows C:/ pathing generated from TouchGFX to the touchgfx-float file when I generated the project in Parallels Windows but didn't think anything of it until I realised I was on my Mac's CubeIDE and that C:// pathing didn't exist anymore. Haha I felt so blind it was there right in front of me.

All works now, I can debug my touchgfx project in Mac CubeIDE on M1, with the project existing on my Mac side instead of inside Parallels.



Thanks for reporting these.

1 and 2 will be fixed in next version.

Associate II

I'd like to report major performance issue with 4.17.

Both Texts and Images lists are beyond slow, rendering a scrolled page takes around 2 seconds. On version 4.16 there's still some lag but is bearable (the project has 430 Texts & 205 Bitmaps).

This many texts makes navigation impossible without any kind of sorting & filtering, so a simple search box for the texts & bitmaps would make this part of the Designer much more usable.

I second for improving the contrast of the UI, the light theme is a step in the right direction, but a bit more dark text would be nicer.

As an overall, we're pretty happy with the product, keep up the good work!


Digging this up a bit, we are currently working on creating a TBS (new name for AT) for the STM32H745. We are also struggling a bit 😅 so it might take a few more weeks unfortunately.



Thank you for those feedbacks. The issues reported are known issues which will be fixed.

As it is a re-design of a software I would advise to stick to TouchGFX Designer 4.16.1 until the release of TouchGFX 4.18 or 19 if the current version does not meet your needs, until those problems are fixed.



Thank you for reporting this. It is a known and really annoying issue we are working on, which should be fixed in TouchGFX 4.18




I want to make a gui template for TouchGFX 4.17.0. Before this version following this link , instead of TGAT, I wrote TGUI and it worked. However, I'm doing same thing for 4.17.0 and I can't see my template in examples. What could I do?


It should still work, nothing has been changed. Could you share your JSON file ? Or maybe even share your tpa if not confidential so that I can try to replicate it.


I'm sorry for the late reply.

I made a simple gui to try. Here are the files :