Showing results for 
Search instead for 
Did you mean: 

STM32H745, Use of TouchGFX, Ethernet and LwIP

Associate II

I am currently working on a project using TouchGFX, Ethernet an LwIP on a STM32H745I board and I was wondering if anyone has encountered a similar issue.

I am using :

  • the firmware package v1.9 for the H7 (I also tried with the v1.10),
  • TouchGFX 4.18 (I also tried with 4.19).

I generated a project with TouchGFX Designer, and imported it on CubeIDE.

Then, I opened the .ioc file for adding the features of Ethernet and LwIP.

After generating the code, it seems that I cannot compile it because "lwip.h" is nowhere to be found, eventhough I can do "open declaration" and it opens a file from the upper folders. Here is a look at the project folders :

There is a Middlewares folder in the upper part but there is no Middlewares folder in the lower part. I tried to generate a project with the H747 board and the Middlewares folder is generated along with other folders :


Has anyone encountered this? Is it meant to be used that way?

Chief II

Dont start create custom projects from TouchGFX.

Bvan .12
Associate II

I am having the same issues, no matter what I have tried I can build in CubeIDE, generate code or simulate in touchGFX but using run target from touchGFX gives errors.

It seems like touchGFX will not acknowledge any include or source paths you add in CubeIDE. I have not been able to find a work around and havn't found much additional information online...ST doesn't even respond to others asking similar questions.

I thought all this would have been fixed in the latest update to 1.10 and 4.20 but I am very close to abandoning their products, way to many bugs and problems. Their are other displays with GUI software that is way easier to work with....or should I say, they actually work.

I can only repeat my first reply.

Normal way for project start is in IDE new project. After add software package touchgfx into it, you will see, that run on target is disabled.

TouchGFX projects is only for demo, learning code without changes or very simple modification.

I've had the same problems and I can't find the answer anywhere. I could not get an answer from ST to a question I also asked about this issue. i have development cards(stm32h745 discovery) with touch screen in different models in my hand, but I can't use it. there are no problems when working with the CUBE IDE alone, but when I create projects with TOUCH GFX, I can't use it because of path errors that can't be found in the "LWIP" Plugins. after adding the paths manually, I keep getting a lot of errors. i think I'll give up using STM products and use other screens for gui designs.