Showing results for 
Search instead for 
Did you mean: 

STM32H747i ethernet cm4: .RxDecripSection and .TxDecripSection


Hi community, 

we referred below link to configure the M4 ".RxDecripSection and ".TxDecripSection"


NOTE: we are running LED Code on cm7 core.

We changed whole RAM to AXISRAM,

We configured as below 

<MemorySegment name="AXISRAM">
<ProgramSection alignment="0x100" load="No" name=".vectors_ram" start="0x24000000" size="0x20000"/>
<ProgramSection alignment="4" load="No" name=".fast_run" />
<ProgramSection alignment="4" load="No" name=".data_run" />
<ProgramSection alignment="4" load="No" name=".bss" />
<ProgramSection alignment="4" load="No" name=".tbss" />
<ProgramSection alignment="4" load="No" name=".tdata_run" />
<ProgramSection alignment="4" load="No" name=".non_init" />
<ProgramSection alignment="8" size="__HEAPSIZE__" load="No" name=".heap" />
<ProgramSection alignment="8" size="__STACKSIZE__" load="No" name=".stack" />
<ProgramSection alignment="8" size="__STACKSIZE_PROCESS__" load="No" name=".stack_process" />

1st tried:

<MemorySegment name="SRAM3_Alias">
<ProgramSection alignment="4" load="No" name=".RxDecripSection" start="0x10040000" size="0x100" />
<ProgramSection alignment="4" load="No" name=".TxDecripSection" start="0x10040100" size="0x100" />

2nd try'

<MemorySegment name="SRAM3">
<ProgramSection alignment="4" load="No" name=".RxDecripSection" start="0x30040000" size="0x100" />
<ProgramSection alignment="4" load="No" name=".TxDecripSection" start="0x30040100" size="0x100" />

In both aspect i tried still we are facing Hard fault error.

                     ==> when i receive data packets of ping command from pc, its going to the hard fault error.


can you suggest where exactly we have to place the sectors for  .RxDecripSection and .TxDecripSection?


Above marked one is not allowing us to modify the values?

how can we solve this issue?



ST Employee

@adam @STM32H743_User @STM32H743_User @SofLit @FBL @Imen.D @TDK @KDJEM.1 



Tagging 9 people is probably a bit much.

If you feel a post has answered your question, please click "Accept as Solution".
ST Employee

Hello @Sandeepc ,

I understand that you want to change " whole RAM to AXISRAM" but you are still putting the descriptors in D2_SRAM3 0x30040000 aliased 0x10040000 for CM4 it seems that you are not setting those in the right place if i understood you correctly.

to further help you locate the miss configuration can you send a copy of the linker file and a snippet of the mpu configuration as well as the modifications added to the Ethernetif.c ,lwipopts.h, files  .


In order to give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.