Showing results for 
Search instead for 
Did you mean: 

STM32H725VGT6 not responding even though it's behaving like it's running. Edit: Solved.

Associate II


I'm working on the FW for STM32H725VGT6 MCU and something strange is happening.

I've created a simple project with cubeIDE (with usart2 and a GPIO to toggle) and the code created and compiled with no issues. After uploading the code with debug mode and running it, everything looks regular and according to the IDE the code is being executed (a test value being increased within the while loop and I can see its value changing in the "watch" window) but actually the MCU is not responding, there's no prints on the UART and the GPIO is not being toggled.

I'm writing the MCU with the STLink of STM32H7 nucleo board.

I'm not new to STM32 MCUs nor to cudeIDE and I never came across such thing.

Also, the boot0 pin is tied to GND.

With the nucleo everything was OK and had no issues.

I remember that the first time I programmed this specific MCU the STM32CubeProgrammer tool send me a message about the option bytes but I don't remember what this message was. There's a chance this issue related to the option bytes?


Associate II

Thanks for all of the answers but my problem's solved.

Apparently I was programming the Nucleo's MCU, even though JP3 (MCR_RST) was open (on Nucleo-H723ZG board).

I've connected my custom board to the JTAG connector of the Nucleo (CN5) and opened JP3 and I though this is how to use this Nucleo as a programmer for another board.

I though I was programming my MCU because all of the other indications suggested that this is the case: for example, every time I've turned off the power to my custom board, the STM32CubeProgrammer tool lost contact with the STM32 targer and was stupid enough not to read the DeviceID of the connected target.

To solve this issue I switched to Nucleo-L476RG as an external programmer to my board and with the two jumpers of CN2 open, I have aclear SWD interface with no issues.