Showing results for 
Search instead for 
Did you mean: 


Senior III

There is a new Digital Power software expansion pack for STM32Cube, X-CUBE-DPOWER.

Does anyone know if the default code generated will immediately work on STEVAL-ISA172V2?

Senior III

Some files can be found in:


just rename the files to .c

Associate III


Because behavior was different when using STM32CubeMX v6.6.1 and v6.7.0, we have issued a new X-Cube-DPower patch version (v1.0.2) for you. The previous problem existing with STM32CubeMX v6.7.0 is now solved, the "DCDC_Control_layer.c" file is now well generated.

Regarding the question about the STEVAL-ISA172V2 usage with this X-Cube-DPower pack : This board version (=V2) is not supported with our pack.

Best Regards

Associate II

Glad to here it's now working.

@PBo​ ,

I disagree when you say "the "DCDC_Control_layer.c" file is now well generated."

There is no generated ***_Control_layer.c thus the generated project has numerous errors.

I tried PSU, Voltage Mode.

First error is,

../X-CUBE-DPower/App/DCDC_Fault_Processing.c:32:10: fatal error: dpwr_pfc.h: No such file or directory
   32 | #include "dpwr_pfc.h"
      |          ^~~~~~~~~~~~
compilation terminated.

Then I tried to comment out #include "dpwr_pfc.h"

Came this second error.

../X-CUBE-DPower/App/DCDC_PWMnCurrVoltFdbk.c:34:10: fatal error: app_dpc_application.h: No such file or directory
   34 | #include "app_dpc_application.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
../X-CUBE-DPower/App/DCDC_IRQ_Handlers.c:33:10: fatal error: app_dpc_application.h: No such file or directory
   33 | #include "app_dpc_application.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
../X-CUBE-DPower/App/DCDC_Fault_Processing.c:34:10: fatal error: app_dpc_application.h: No such file or directory
   34 | #include "app_dpc_application.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
compilation terminated.
../X-CUBE-DPower/App/DCDC_Globals.c:35:10: fatal error: app_dpc_application.h: No such file or directory
   35 | #include "app_dpc_application.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
../X-CUBE-DPower/App/app_X-CUBE-DPower.c:40:10: fatal error: app_dpc_application.h: No such file or directory
   40 | #include "app_dpc_application.h"
      |          ^~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

Sorry, not working.

You can verify yourself.

Associate III

Dear @victagayun​ 

We are confident there is misusage of the pack. So, we would like to help you to get it right.

Please, could you clarify the following information to start-up understanding your trouble:

1/ HW configuration :

1.1/ ioc file used ?

1.2/ HW board used ?

2/ SW configuration :

2.1/ STMCubeMx version used ?

2.2/ IDE and version used ?

3/ FW configuration :

3.1/ Which topology are you using ?

Thanks for your answers.

Best Regards

OK, I overlooked that there is a newer version 1.0.2.

So far I have checked the following:

1. PFC - Interleaved Boost G474inFQFP64 = can be compiled without a problem.

2. PSU - Buck VoltageMode_SW G474inLQFP64 = missing files, dpwr_pfc.h and dpwr_pfc.c, need to copy manually.


Associate II

I have the B-G474E-DPOW1 Discovery kit and I have downloaded the Buck_VoltageMode_HW project from ST repository. I build the project without error and it runs as expected.

After double click on ioc file the ST32CubeIDE suggest me to migrate to MX ver. 6.7.0

After the migration, the project compiles and runs as expected.

At this point I have downloaded and installed the X-CUBE-DPOWER software pack ver. 1.0.2 from ST repository.

I have made the selection as in the following imagine:

0693W00000YAWL2QAP.jpgNOTE: Only X-CUBE-DPOWER is 1.0.2 but the components of the software pack are 1.0.1 or 1.0.0.

0693W00000YAWL7QAP.jpgAfter the selection I click on the button Device Configuration Tool Code Generation and all is ok.

After this operation I close the ioc editor.

At this point I bulid the project but I have the following error:

In file included from C:/STMicroelectronics/Projects/Buck_VoltageMode_HW/Src/DCDC_Control_Layer.c:32:

../../Inc/app_dpower.h:33:10: fatal error: DPC_Miscellaneous.h: No such file or directory

Tools version:

STM32CubeIDE: Version 1.11.2

STM32 Device Configuration Tool (MX): Version: 6.7.0-RC4

X-CUBE-DPOWER package ver 1.0.2

Thanks for the support

You can copy the .ioc from

Repository\Packs\STMicroelectronics\X-CUBE-DPower\1.0.2\CubeMX Files References to your workplace and import. That would be PSU - Buck VoltageMode_SW G474inLQFP64.ioc. After which, you will end up with missing files, dpwr_pfc.h and dpwr_pfc.c. You just need to copy manually from Repository\Packs\STMicroelectronics\X-CUBE-DPower\1.0.2\Middlewares\ST\Third_Party\Biricha.

Associate II

After some test I have found this way for compiling the project:

I have selected the button Start new project form STM32CubeMX file (.ioc)


Then I have selected the file PSU - Buck VoltageMode_HW G474inLQFP64.ioc

The file is at the following path:

C:\Users\user1\STM32Cube\Repository\Packs\STMicroelectronics\X-CUBE-DPower\1.0.2\CubeMX Files References\


During the import of the ioc file I receive the following message:


Then I select to migrate.

At this point if I compile the project I have the following error:

../DPower/App/DCDC_Fault_Processing.c:32:10: fatal error: dpwr_pfc.h: No such file or directory

  32 | #include "dpwr_pfc.h"

I have found the file at the following path:


0693W00000YAXGSQA5.jpgI have copied the file at this path of my project:

C:\STMicroelectronics\Projects\PSU - Buck VoltageMode_HW G474inLQFP64\DPower\App\


After this I compile the project with success.

Thanks for the support