Showing results for 
Search instead for 
Did you mean: 

ST Motor Control Workbench Stuck at project generation

Associate II

Hi there!

I am trying to spin a motor with a STM32F3 MCU and the Motor Control SDK.

I am able to use the Motor Profiler to generate a profile of my PMSM and spin the motor via the computer. Importing the motor profile into the ST Motor Control Workbench also works fine.

When I try to generate the project files in the ST Motor Control Workbench, no files are generated and the window seems to be stuck forever without any log output in the project file generation window or in the main window.

My Setup:


- NUCLEO-F302R8 Logic Board

- X-NUCLEO-IHM07M1 Power Stage



- STM32CubeIDE 1.4.0

- STM32CubeMX 6.4.0

- Motor Profiler 5.Y.3

- Motor Control Workbench 5.Y.3

- "Firmware Package Version" was installed via CubeMX, is found by Motor Control Workbench and is available in: STM32FW V1.11.2 and STM32FW V1.11.3

Computer HW/SW:

- Tried on two machines with WIN10, both show the same result.

My Steps so far:

- Assemble HW (stack the two boards, attach Motor (maxon ECi))

- Connect Nucleo Board to PC

- Connect to Board via motor profiler

- Update FW on Nucleo Board via motor profiler (probably had some other stuff on it...)

- Run Profiling and save

- New Project in ST Motor Control Workbench with motor profile

- Check Pinout - ok

- Generate Code via dialog. Tried all Versions of the Firmware Package Version and both HAL and LL options.

- The Window "Project Generation" then stays open forever and does not show any log output or files.

Any Ideas how we can get this to run? Any Input is highly appreciated!

Thanks and stay safe!


Associate II

i have facing the same problem here its showing library is not installed but i installed cubemx library

you can visit this link

Associate III

Note to everyone - new release of MCSDK:

V5.Y.4 / 18-Jan-2022

Main Changes

Version 5.Y.4 of the Motor Control Software Development Kit (X-CUBE-MCDSK) is a bug fix release of version 5.Y.3. Its main purpose is to add support of STM32CubeMx version 6.4.0.

Associate II

The new Version 5.Y.4 work's great now! THX to ST!

Associate II

Hi, i was to optimistic. It is now possible to generate a code with the 5.Y.4 and STM32CubeMX 6.4.0, but there are Faults. It was possible with the MX 6.3.0 but could still be a parameter setting on my side.

There is one strange red fault is: The ST intranet updater server is unknown:

In the Motor SDK:

Type Time   Motor  Id  Message

UNK  10:26:56        Generation files starting

UNK  10:34:34        Generation failed

In the IDE 1.4.0 after buid there is a fault:

../../Inc/mc_stm_types.h:171:20: error: '_01HZ' undeclared (first use in this function); did you mean 'U_01HZ'?

make: *** [Middlewares/MotorControl/ Middlewares/MotorControl/encoder_speed_pos_fdbk.o] Error 1

make: *** Waiting for unfinished jobs....



I have same problem with MCSDK 5.4.8. but downgrading to cubemx 6.3 has no success.

choosing any ide does not change any thing.

some errors occur when generating project. I attach my log here please Help.


Still Having Problem.

any solutions?

I want to use F1 MCU series and can not migrate to 5.Y.x...

any help is appreciated.