Showing results for 
Search instead for 
Did you mean: 

PowerStep01 not rotating the stepper when given move command


Hi everyone,
Recently I bought a couple of Nucleo-IHM03A1 PowerStep01 Evaluation Boards. I am planning to use these to run a wheel, that will move a body on a rail. The movement needs to be precise, so I decided to go with an Stepper Motor. The motor I choose is RMCS-1004 (which is a NEMA34 Motor with 6A coil ratings). I am supplying the IHM03A1 board with 24V DC from a 24V 5A Adapter. I have mounted the Expansion board on a Nucleo-F030R8 that I had laying around.

My problem is as follows:

I am not able to run the motor when I send SPI command about the same.

The command i am sending is {0x41, 0x00, 0x0F, 0xA0). Which is derived as follows:

Move Address: 0100000x (x being direction). This is followed by number of steps to be moved which are 22 bits. I want the stepper to move 4000 steps, so 0x000FA0.

I am attaching my code for reference. Please guide me where I am at fault. 

P.S. I tried using almost similar command to the given STM example code, but it did'nt work. I have tried many combinations which are all commented out for you guys to take a look at.

I also checked on Salae logic analyzer if I am doing something wrong, but to my untrained eyes both the commands of my code and the STM stack were similar. 
Also STM stack is working almost perfectly. However I am unable to use that stack in my code as it is too complex for my understanding (sorry). If anyone can help me integrate that into my code, that would be great too.

Please ignore any silly errors as I am not a seasoned programmer.