Showing results for 
Search instead for 
Did you mean: 

STM32H7B3I-DK Board Issue: Faulty LD7 and No STM32 Target Found

Associate III

Hi Community,

I am currently facing an issue with my STM32H7B3I-DK board. The board was working fine, but suddenly, while I was uploading the code, the LD7 LED turned on indicating a low voltage fault. However, I am confident that the USB is providing the correct voltage.

In an attempt to resolve the issue, I tried upgrading the firmware and used CubeProgrammer to reset the board with a shown voltage alternating between 0.21v, 0.35v and 0v. I also tried using the STLink utility, but I keep getting the “No STM32 Target found” error, and there is a Fail File existing in the mass storage when connecting the board containing "The interface firmware FAILED to reset/halt the target MCU".

Additionally, I noticed that the WiFi LED (LD1) and the 5V Power LED (LD5) are weakly lit. I am unsure if this is related to the current issue or if it’s a separate problem.

I have been searching for solutions online and tried several suggested methods, but none have worked so far. I would appreciate any help or suggestions on how to resolve these issues.

Troubleshooting Steps Taken:

  1. Upgraded the firmware.
  2. Used CubeProgrammer to reset the board.
  3. Utilized STLink utility to erase memory.

Current Issues:

  1. LD7 LED indicating low voltage.
  2. “No STM32 Target found” error.
  3. Slight lighting of WiFi LED (LD1) and 5V Power LED (LD5).

Board Details:

  • Board: STM32H7B3I-DK
  • Power Source: USB

I hope it's not a faulty hardware component, I appreciate any assistance!


That does sound like a lot of inadvisable actions.

The ST-LINK Utilities predate the STM32H7Bx, so wouldn't be using that for any predictable out come.

Might suggest strapping BOOT0 to ground, power cycling the board completely a couple of times, and them trying to connect and mass erase using STM32 Cube Programmer

Perhaps consider what you were doing when it failed, perhaps incorrect LDO/SMPS settings, of VOS settings. Board siting on a conductive surface, or other connectivity which might has caused shorts, or high voltages from external sources.

Review the schematic, see if you can check voltages / expectations at various points.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

@Tesla DeLorean Hi, thank for replying, The board doesn't provide access to boot0 pin externally, I saw the schematic as you said, I found where it is situated but I can't strap it to ground, Do you think there is another solution ?