Showing results for 
Search instead for 
Did you mean: 

STM32 Nucleo F446RE not being detected anywhere on laptop


My STM32 Nucleo F446RE is not being detected on my laptop - neither in my device manager (its not under Ports nor the Universal Serial Bus Controllers dropdowns), nor is it being detected in the Cube IDE. A couple of things I have noticed:
- The power led, LD3, is on when its connected to my laptop, and is red.

- The COM led, LD1, doesn't turn on

- The underside of my board gets hot, even if it's just connected to my laptop, with no other peripherals or devices connected or wired to my STM32 board.
- Note, this isn't my first time flashing code with this specific board. I bought it a month ago and during this month it was working fine, but I was working on a project connected to a motor driver and a power supply, and when I tried to flash the code from the Cube IDE on my board while working on this project, it said "No ST-Link detected! Please connect ST-Link and restart the debug session"
- Also note, I am using ST-Link GDB Server as my debugger if that matters

Troubleshooting solutions I have tried:
- Rebooted my computer

- Rebooted the Cube IDE
- Took the cable out and plugged it back into my computer

- Deleted and reinstalled STM32 Cube IDE and its associated drivers

- Used a different USB-mini cable, and a different port for connecting the board to

Any other possible solutions I can try?

ST Employee

Hi @asmi-g ,

If you still face the issue, or for any other one who have similar problem, you can find some tips in these 2 articles:


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.

>>Any other possible solutions I can try?


They shouldn't get hot to the touch unless something is internally shorted.

The boards should not be used on a conductive bench or desk.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

>The underside of my board gets hot

What about the 2 cpus - hot ?


I was working on a project connected to a motor driver and a power supply

So fried one or both cpus , by a spike or current on gnd / loosing gnd connection, etc.


At the price range of this nucleo - replace it (as Tesla said ) and take better care next time, connecting or disconnecting anything with > 5V to a running cpu.

If you feel a post has answered your question, please click "Accept as Solution".