cancel
Showing results for 
Search instead for 
Did you mean: 

Hi, I am using L6235Q Evaluation board for my brushless motor. I connected the board to the motor and the motor not moving. the connection is so simple but the motor is not moving.

IGAL TALOR
Associate II

I am using 12V motor, all the phase I measured 12V, its look like it stuck at brake.

what can be the problem?

I am using motor 1028m012b - FAULHABER

23 REPLIES 23

I confirm that the only configuration that brings all outputs high is the brake function.

Try to verify the voltage as close as possible to the BRAKE pin (#20), if is correctly set high.

IGAL TALOR
Associate II

I checked pin 20 =5V.

also checked pin 19 and i found that Vref is 0V,

the problem with the evaluation board, I connected J6 2-3 and J3-11 to 5V, and no vref voltage.

still the motor not moving, but now I see current consumption from my power supply.

IGAL TALOR
Associate II

I measured PIN 20 BRAKE = 5V

checked PIN 19 VREF = 0V

the problem is with evaluation board I connected J6 2-3 and powered J3-11 with 5V and no voltage to VREF.

now I powered the VREF and I see power consumption but still the motor not moving.

IGAL TALOR
Associate II

The schematic of the evaluation board is not correct.

IGAL TALOR
Associate II

The motor at the power up try to move but not moving (feel vibration at the start).

the HALL EFFECT H1=0 H2=1 H3=0 not changing.

Cristiana SCARAMEL
ST Employee

Hi @IGAL TALOR​ for easier reading, please try to concentrate the information in a single post.

Where you are applying the VREF voltage instead of J3-11?

Are you applying the 5V to the J3-1 pole?

If you identify a mismatch between board and schematic please share the information, thanks.

IGAL TALOR
Associate II

the VREF from J3-11 is not connected as shown at the schematic, I checked it with FLUKE.

now I connected VREF from J8-3.

Do you know about another mismatches?

Hi @IGAL TALOR​,

I checked the board connection: the silkscreen of J6 solder bridge is swapped compared to the schematic.

The right info for VREF source selection is reported in the figure 1 of data brief .

If the issue persist I suggest to check all the IC pin status with a oscilloscope probe (not multimeter).

Hi @IGAL TALOR​ ,

are there any updated about your project progress?

IGAL TALOR
Associate II

HI,

I am waiting for a new motor that I ordered.

I think that the motor that I used was damaged.

the hall effect not changing.