STM32CubeProgrammer (MPUs)

cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Why STM32cubeProgrammer suddenly stopped working & OpenFile tab is not accepting mouse click, Neither navigating to brows file option?

@hello, I was using STM32Cubeprogrammer for long time but suddenly Its main function of browsing and selection file option (OpenFile) stopped working. After multiple time install and uninstall it has the same behavior in a particular PC. I tried olde...

0693W00000Un8uPQAR.png
PS.2 by Associate II
  • 1007 Views
  • 8 replies
  • 1 kudos

Error installing stm32cubeproj 2.12.0 SEVERE: com.izforge.izpack.api.exception.IzPackException: Console implementation not found for panel: com.st.CustomPanels.AnalyticsPanels

WORKING:> sudo java -jar SetupSTM32CubeProgrammer-2.11.0.exeFAILS> sudo java -jar SetupSTM32CubeProgrammer-2.12.0.exeCompletely uninstalled JAVA, then reinstalled - no change.Reviewed several community posts, no solution yet.Environment: macOS Big Su...

GJet7 by Associate
  • 1209 Views
  • 5 replies
  • 4 kudos

Installing the STM32CubeProgrammer without GUI

I have a Ubuntu 22.04 server I use for building Yocto distros for the STM32 MPUs. I would like to install the programmer on that so I could run some automated tests and flashing on my build images. Is it possible to install the software without the G...

salmmike by Associate II
  • 1550 Views
  • 6 replies
  • 0 kudos

Resolved! How to install STM32CubeProgrammer on Raspbian?

Hi there, I want to flash a HEX file using a Raspberry PI. So I followed the steps described here.But if I run this line:$> ./SetupSTM32CubeProgrammer-2.13.0.linuxI get the message:bash: ./SetupSTM32CubeProgrammer-2.13.0.linux: cannot execute binary ...

Moritz1 by Associate III
  • 967 Views
  • 3 replies
  • 0 kudos