Showing results for 
Search instead for 
Did you mean: 

cubeMX6.0.1 + cmsis dsp library for cubeIDE 1.4.2 = compile error, "RTE_Components.h" not found.

naser moravej
Associate III

I want to use dsp libraries on cubeIDE 1.4.2 with cubeMX 6.0. I used this library on cubeIDE 1.3.1 version with cubeMX 5.6 but after I updated cubeIDE and cubeMX, even though I didn't add any code, code generated didn't compile.

My board is stm32f429 discovery board.

I selected my boad in cubeMX, I installed CMSIS 5.6 in "Embedded Software package manager", then I checked the boxes as it shown in picture. I generated the project and compiled with cubeIDE 1.4.2. but I got "RTE_Components.h" not found error. I found this library and added to my project but I've got another error.

l tried to use dsp library like I did on cubeIDE 1.3.1 version by adding "arm_cortexM4lf_math" but it didn't work.

Any solution?0693W000002lCkDQAU.jpg

Khouloud ZEMMELI
ST Employee

Helo @naser moravej​ ,

Thanks for your feedback , in fact, this's not a CubeMX issue, it's a specific problem with ARM packs and we are sorry for that... you need to generate a keil project in this case, so It's not possible to fix the issue from MX side as the RTE_components.h can be generated by CubeMX only if there is some RTE_components into the PDSC .

For the chosen component , there is no RTE element

Best Regards



Thanks for your answer. I don't understand.

  1. Do you mean I have to use keil instead of cubeIDE in this case? if your answer is yes, I tried but I got: ../CMSIS/Target/main_s.c(26): error: #5: cannot open source input file "arm_cmse.h": No such file or directory
  2. As I said, I could use dsp library in previous version of cubeMX and cubeIDE with some difficulties, but I don't know which one is my problem, Do I have to use cubeIDE previous versions or cubeMX.
  3. According to what you said, I understand RTE_componenst.h like this might works, but I don't know whether its wrong?
 * Define the Device Header File: 
#define CMSIS_device_header "stm32f4xx.h"
#define RTE_Network_Interface_ETH_0     /* Network Interface ETH 0 *//* I have a network interface in my project and it uses socket tcp*/
#define RTE_Network_Socket_TCP          /* Network Socket TCP */
#endif /* RTE_COMPONENTS_H */