Showing results for 
Search instead for 
Did you mean: 

STM32CubeIDE/ Cant add library to project file

Associate II

Hi all,

Im having problems with my IDE, I cant seem to add the stm32f407xx.h library to my project, which is an internal library provided by ST. I added it to the linker GCC both the path to the file directory and the file itself and its still not accepted by the compiler.





Accepted Solutions

Your project structure is missing the drivers: CMSIS and HAL:


I invite you to look at one of the examples provided by STM32CubeF4:

example: to show how a project is structured.

Or simply generate the code with CubeMx. It will generate all the needed drivers' files.

PS: looking at your main.c file: I don't recommend to start with direct access to the registers from the beginning. Start by using HAL then switch for an optimization as you did.


To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

View solution in original post

Ghofrane GSOURI
ST Employee

Hello @ADyankov 

I would appreciate it if you could tell me which version of STM32CubeIDE you are utilizing and your operating system.

I will be waiting for your feedback.




Hello @Ghofrane GSOURI,

Im using version 1.14.1 and Im running it on windows 10.


Hello again @ADyankov 

Actually I created a project using version 1.14.1 on windows 10 and everything works correctly after adding the 

#include <stm32f407xx.h> as you did 


So make sure that  the firmware FW_F4 is installed correctly  and  stm32f407xx.h does exist in your directory also make sure that  the required paths are added correctly under GCC compiler .



I did the same as you and now it accepted the library path on compile it gave the following output.




Associate II


Here I write a simply program for one of the LED's on the 407 discovery board using the stm32f407xx.h library and it states as there are no changes so nothing to be compiled.

Hello @ADyankov 

Could you please provide a screenshot of the entire error message?

Hello @Ghofrane GSOURI 

Here is a log file of the error msg.

Pavel A.
Evangelist III

@ADyankov Where your project comes from? Was it generated by CubeMX/IDE?

Have you installed the firmware library package for STM32F4? (X-CUBE-TOF1 is not enough, please install the STM32F4 library too)


Hi @Pavel A., the project is generated by CubeIDE, the libraries are present in the directory of the software itself.