Showing results for 
Search instead for 
Did you mean: 

STM CUBE IDE can not program the board.

Senior II

Hi All,


I am having an issue which is persistent for more than a week. I created a simple blink LED program using STM32 CUBE IDE IDE. I compiled it OK. Then, I tried to run it on the board, CUDE IDE got stuck. I can see from the progress bar that Launching: initializing debugger services. The progress is stuck at %51 and does not change even if I wait for ages. To identify the root cause, I tried below steps.

  • I tried with another cable but didnt work
  • I tried with another version of STM CUBE IDE (1.13.0) and it did not work
  • I tried to program the board with STM Cube programmer and it WORKED, I was able to blink the LED.
  • I tried to use another PC and it also WORKED

So, it got me thinking that STM CUBE IDE on my PC has something wrong. As I can not purchase another laptop as a solution, I am looking forward to hearing some help from the community. Please see attachments and provide me some guidance.

Thank you in advance.


Mahmoud Ben Romdhane
ST Employee

Hello @demir ,

I suggest that you provide the board that you are using.



Sorry Mahmoud, I totally forgot that.

It is ST32F407G-DISC1 (MB997E).

Hello @demir ,

For more investigations, I suggest that you provide please the Debug session configurations and the File. You can find it under Properties (Alt+Enter)> C/C++ Build>Logging.





Senior II

Hi Mahmoud,

Please find it below.

09:28:42 **** Incremental Build of configuration Debug for project blinking ****
make -j8 all
arm-none-eabi-gcc -o "blinking.elf" @"objects.list" -mcpu=cortex-m4 -T"C:\Users\blinking\STM32F407VGTX_FLASH.ld" --specs=nosys.specs -Wl,-Map="" -Wl,--gc-sections -static --specs=nano.specs -mfpu=fpv4-sp-d16 -mfloat-abi=hard -mthumb -Wl,--start-group -lc -lm -Wl,--end-group
Finished building target: blinking.elf

arm-none-eabi-size blinking.elf
arm-none-eabi-objdump -h -S blinking.elf > "blinking.list"
text data bss dec hex filename
35620 132 4124 39876 9bc4 blinking.elf
arm-none-eabi-objcopy -O ihex blinking.elf "blinking.hex"
Finished building: default.size.stdout
arm-none-eabi-objcopy -O binary blinking.elf "blinking.bin"

Finished building: blinking.list
Finished building: blinking.hex

Finished building: blinking.bin

"make -j8 all" terminated with exit code -1. Build might be incomplete.

09:28:49 Build Finished. 0 errors, 0 warnings. (took 6s.963ms)

Pavel A.
Evangelist III

"make -j8 all" terminated with exit code -1. Build might be incomplete.


Can you check how much free space you have on the disk?

In the project settings, remove creation of bin and hex files unless you need them specifically.


Seems your build config is ok , but debuger setup completely fail. create new debug configuration in debug button menu.

Hi Pavel,


Hex and bin files are already not generated. I have 48gb available disk space.

I dont know why the build fails, how can I correct it ?

I havent played with configuration, it is all default. Could you pls direct me what to check ?



Pavel A.
Evangelist III

Everything looks good, except of the unexplainable make error. Then it looks indeed like a problem with your computer. Windows is a complicated system, too many things can go wrong in it.