cancel
Showing results for 
Search instead for 
Did you mean: 

st-stm32cubeide_1.11.2_14494_20230119_0724.unsigned_amd64.deb_bundle.sh install issues

MBisk.1
Associate

Trying to install on Windows 11 WSL2 Ubuntu 22.04.1 and get the following after accepting license:

Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

Note, selecting 'st-stlink-server' instead of './st-stlink-server-2.1.0-1-linux-amd64.deb'

Note, selecting 'st-stlink-udev-rules' instead of './st-stlink-udev-rules-1.0.3-2-linux-all.deb'

Note, selecting 'st-stm32cubeide-1.11.2' instead of './st-stm32cubeide-1.11.2-14494-20230119-0724.unsigned_amd64.deb'

Note, selecting 'segger-jlink-udev-rules' instead of './segger-jlink-udev-rules-7.82b-linux-all.deb'

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

 st-stm32cubeide-1.11.2 : Depends: libncurses5 but it is not installable

                         Depends: libpython2.7 but it is not installable

E: Unable to correct problems, you have held broken packages.

Any ideas?

4 REPLIES 4
MBisk.1
Associate

Installed libncurses5 and libpython2.7 on my wsl Ubuntu system and now the installer is running.

Ed Peguillan III
Associate

EDIT: I forced my newer version of `libpython2.7` to uninstall, which caused me to lose those programs that depended on that version. But after doing so, the ST installer worked fine.

Original text:

I am having the same issue, but cannot install the specific python version the `.deb` files are requesting. The ST installer's `.deb` files want `libpython2.7-stdlib=2.7.18-8`, but I am only able to install `libpython2.7-stdlib=2.7.18-13.2` (which is a later version, I think?). It would probably work if the `.deb` installers were modified so they could accept `libpython2.7-stdlib=2.7.18-8` and later versions.

Raees
Associate II

Getting a similar error on Ubuntu 23.04. "st-stm32cubeide-1.12.0 : Depends: libpython2.7 but it is not installable"

Surprised to see ST32CubeIDE still depends on Python 2.7 which is marked as the end of life in Jan 2020

ABans.3
Associate II

same I just installed the kubuntu 23.04 and struck with the installation of cube ide.