cancel
Showing results for 
Search instead for 
Did you mean: 

Project imported from TouchGFX but not able to debug for board STM32H745I - DISCO

Chaitanya1997
Associate II

@Osman SOYKURT 

Board : STM32H745I - DISCO

Cubeide : v.1.13.2
TouchGFX : v4.22.1 Designer

i did generate code in touchgfx then imported the entire project in cube IDE.


STM32H745I - DISCO as it is dual core m4 and m7
1st i did build and debugging for STM32H745I_DISCO_CM4 <--- (check in image). It is successful.
2nly done with building for STM32H745I_DISCO_CM7 <--- (check in image) .It is successful
But while debugging the STM32H745I_DISCO_CM7 ;

i am facing following issue ??????

 

 

Error in final launch sequence:

 

Failed to execute MI command:

load C:\\TouchGFXProjects\\T_First_Project\\STM32CubeIDE\\CM7\\Debug\\STM32H745I_DISCO_CM7.elf

 

Error message from debugger back end:

Load failed

Failed to execute MI command:

load C:\\TouchGFXProjects\\T_First_Project\\STM32CubeIDE\\CM7\\Debug\\STM32H745I_DISCO_CM7.elf

 

Error message from debugger back end:

Load failed

Failed to execute MI command:

load C:\\TouchGFXProjects\\T_First_Project\\STM32CubeIDE\\CM7\\Debug\\STM32H745I_DISCO_CM7.elf

 

Error message from debugger back end:

Load failed

Load failed

1 ACCEPTED SOLUTION

Accepted Solutions
ngrigoriadis
Associate III

Hello, considering what you mentioned above, I think that it has to do with your run configurations. Could you please share with us what run configurations you have? How do you connect the screen with the PC? In the run configuration format you have to find the proper .elf file for your screen and define it in the main option. I have posted a picture, which is showing what run configurations I have for another screen (Riverdi). 

View solution in original post

5 REPLIES 5
ngrigoriadis
Associate III

Hello, considering what you mentioned above, I think that it has to do with your run configurations. Could you please share with us what run configurations you have? How do you connect the screen with the PC? In the run configuration format you have to find the proper .elf file for your screen and define it in the main option. I have posted a picture, which is showing what run configurations I have for another screen (Riverdi). 

https://www.youtube.com/watch?app=desktop&v=jI1k6p-fduE

I followed above video and changed the run setting of project

So I suppose that I helped you to search something in order to find the solution. Could you please accept my reply as an answer?

Imen.D
ST Employee

Hello @Chaitanya1997 ,

I recommend you follow this application note AN5361 in "3 Debugging" section, that covers the configurations needed to debug STM32H7 Series Dual-core in STM32CubeIDE.

Imen

When your question is answered, please close this topic by clicking "Accept as Solution".
Thanks
Imen

YES 
i followed the same steps given in manual then also facing the same issue for debugging.

Could please check the same at your end ??