Showing results for 
Search instead for 
Did you mean: 

Jumping to random file after pressing Run button

Associate II

Hello. When I press to Run (Run main.c) button, STM32CubeIDE opens random file, possibly, from current repository, for example: startup_stm32l452xx.s, core_cm4.h etc...

Code is loading successful, but this side effect bothers me.

I would like to disable this function. How can I do it?

If you need more information about this behavior please, ask.

Thank you for reading.


Same issue, version: 1.14.0. New notebook, new Win11 installation, new CubeIDE installation. Problem started at the very first project (I started to learn programming MCUs recently) . 

Senior III

They claim to have fixed something...



I am running 1.14.1 under win7-64 and on a quick test it seems ok. It does open the startup.s file at the 1st line where SP is loaded, but that is ok (well, it's dumb). Afterwards whenever I press e.g. the stop button it opens tasks.c at void vApplicationIdleHook (void) which is correct because that is where the CPU spends by far most of its time in my project (and probably in most RTOS-based projects).

BTW the system requirements, which now say win10 or higher, is BS. It works perfectly under win7-64. I know official M$ updates stopped years ago but there is a way to fully update win7-64 because M$-contract customers still get it.



sorry that is not true.

The issue is not solved in 1.14.0 nor in 1.14.1

They mark a issue as "solved" as soon they generate a ticket.






4 Years later and this unexpected behaviour continues...😬

I cannot believe you couldnt reproduce, because in the office 3 people using it and me i use 2 laptops and all does the same after Programming with STMCubeIDE from 2018 till now versions.
I am in main.c tab, but during programming TABS "change" randomly to any other file. If not file open in a tab , it opens any anyway .


Just updated to 1.15.1, and this bug is still present. Especially annoying when exiting debug mode to update the code, a random *.s file would open and instead in main, I would start typing in the *.s file.

Please ST, you have been aware of this for years!

Senior III

@GeneralTaoCan you please unmark the answer as an answer. I finally thought the issue was solved, but you incorrectly marked it as solved.

Kudo posts if you have the same problem and kudo replies if the solution works.
Click "Accept as Solution" if a reply solved your problem. If no solution was posted please answer with your own.
Lukasz Nowak
Associate III

STM32CubeIDE 1.16.0 still has the same problem - 100% reproducible.

Hey, ST - will this ever be fixed?

I cannot believe you can just keep ignoring this problem for years now...

Associate II

And do you know what is even more "funny" ??..  using STM32 extension in VScode it has same behaviour after build/compile or run the project ! 😳🙄