cancel
Showing results for 
Search instead for 
Did you mean: 

How can I change UI size in .ioc file view?

AO7
Associate

AO7_0-1712289415455.png

Hello community!!


I'm using Ubuntu 22.04 with 4k monitor and my fractional scaling set to 175%, and this is what I get in STM32CubeIDE .ioc file view, which is too small to read.

I tried toggling some font settings in Window > Appearance, but didn't work.

Therefore I want to know if there's a way to change the UI size or font size of the view?

3 REPLIES 3
ACapo.1
Senior

Hi @AO7 

You didn't by any chance work out how to change the size?

Thanks

Andy

deliverredt
Associate

settings, as STM32CubeIDE is based on the Eclipse IDE. Here's a step-by-step guide to adjust the font size:

  1. Open STM32CubeIDE: Launch STM32CubeIDE on your Ubuntu system.

  2. Access Preferences: Go to the "Window" menu at the top of the screen and select "Preferences." Alternatively, you can press Ctrl + Alt + S to open the Preferences window.

  3. Navigate to Appearance Settings: In the Preferences window, expand the "General" category and select "Appearance."

  4. Adjust Font Size: In the Appearance settings, you should find options to adjust the font size. Look for settings related to "Text Font" or "Colors and Fonts." You may need to experiment with different font settings until you find the one that suits your preference.

  5. Apply Changes: After adjusting the font size, click on the "Apply" button to apply the changes. You might need to restart STM32CubeIDE for the changes to take effect.

If adjusting the font size through the Eclipse settings doesn't work as expected, you can also try changing the scaling settings directly in Ubuntu:

  1. Access Display Settings: Go to your Ubuntu system settings and open the "Displays" settings.

  2. Adjust Scaling: In the Displays settings, look for an option to adjust the scaling or DPI settings. You can try increasing the scaling factor to make UI elements larger and more readable on your 4K monitor.

  3. Apply Changes: After adjusting the scaling settings, close the settings window, and check if the UI elements in STM32CubeIDE are now more readable.

Hi @deliverredt 

Thanks for the reply but everything else in eclipse is fine, it is just the ioc viewer that is wonky.

I just found a solution though:

1. Quit stm32cubeide

2. install the standalone STM32CubeMX app, run it, at the top click window and then Choose the size you want.

3. Quit STM32CubeMX

4. Start stm32cubeide and the ioc viewer will use those settings.

Thanks

Andy