Showing results for 
Search instead for 
Did you mean: 

FAIL.txt file appears on the disk.


Once I connect my board(f746-disco), there is a disk in which FAIL.txt appears which contains "The interface firmware FAILED to reset/halt the target MCU". I have been getting this error since yesterday. I found a question asked this community, it was recommended to update STLink. However I did this, the problem is not solved. Moreover, I removed and re-installed CubeIDE, but the problem still continues. When I try to upload a code via Cube IDE, I got

"Error in final launch sequence:

Failed to start GDB server

Failed to start GDB server

Error in initializing ST-LINK device.

Reason: (4) No device found on target."

What can I do? Please help me it is very very urgent, it is vital for me.

Thanks for your help.


Is the board powered correctly? (test with multimeter)

Did it stop working or it just never worked?

What does stop working mean? The power led is lighting, but I cannot upload code to board.

Which part/component should I measure on the board?​

And thank you for your answer.​

What changed/happened when it stopped working.

C​heck jumpers related to powering board and STM32 chip.

Check ​connectivity of SWD/JTAG pins, see jumpers or solder bridges.

Current measuring jumpers?

Option bytes or Read Out Protection, RDP2 ??​

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

To check all these,​ I need to look at schematic, dont I?

I ​have no idea what happened to my board and it stopped working. I just wanted to use built-in microphone, I configured everything, then plug the board to my pc, but I see the text file on the disk :(.



I researched more on Google, and saw some suggestion to use ST-Link Utility. At first, I connect NRST pin to 3.3V, and then used erase chip on st-utility, after that I uploaded a code(.hex file) compiled on MBED studio. The code works when I connect NRST to 3.3v, but now ST-Utility cannot see my device.