Showing results for 
Search instead for 
Did you mean: 

My MCU (STM32H750B-DK) used to work normally but now the IDE shows error when I try to debug or communicate with it.

Associate II

After using the MCU with no problem for weeks, i was trying to test a FDCAN application together with a raspberry pi, after that day, it's been having problems, it fails to connect to cube programmer, and it fails to run code that used to work perfectly.

Details about the errors I get:

I get different errors on different situations:

"no ST-link detected, Please connect ..."

If I change the debug configuration Reset behaviour I get:

"Failed to start GDB server, no device found on target"

If I try to connect from STMcubeProgrammer it can't unless I follow these steps:

turn the MCU on while pressing reset,

close the window that prompts in my screen showing the contents,

Click connect,

Release RESET.

This allows me to MASS erase.

I go back to the IDE and it allows me to upload code to debug but it shows this warning:

"Break at address "0xfffffffe" with no debug information available, or outside of program code."

if I click "open disassembly" it goes to this line:

"080002dc:  bl   0x8000a18 <HAL_Init>"

After this, if I try to do "step over" or any other instruction or upload more code, it fails again (no ST-link detected).

I have tried changing the debug configuration, and reinstalling the IDE.

mattias norlander
ST Employee


Please provide more details.

  • Q1: So all the bad behavior started after you tried to debug an FDCAN application?
  • Q2: Is this application part of a CubeFW delivery from ST or is this your own project?
  • Q3: Is it possible that you damaged the board when connecting it to the RPi? RPi should also be 3.3v though...
  • Q4: Have you or the FDCAN application modified the Option Bytes in any way?
    • You should be able to connect with CubeProg under reset to read these out. Maybe you can post them here.

Associate II

Hello Mattias, thanks for the help

Before I answer the questions, I have new information:

I installed the CubeIDE in a coworker's PC and everything worked fine in there. That leads me to believe that the problem is in some IDE configuration and not in the board itself. Just reinstalling th IDE doesn't fix it for me though.

¿Is there a way to return the IDE to factory setting, or to completely erasing it before reinstalling?

¿Any suggestion is a big help?



mattias norlander
ST Employee

I am wondering if this problem is not at all related to running the FDCAN demo. Maybe just a coincidence?!

Maybe something in your PC environment has changed?

  • Some update to anti-virus software
  • Or firewall
  • Or driver update?
  • Do you know if your IT-department deployed any updates that could mess with your environment?

Could you temporarily disable any anti-virus / firewall? And try debug?

I also don't think the problem is inside the IDE itself since you say that also CubeProgrammer does not work as intended. The common denominator would be drivers for the ST-LINK. Maybe try to re-install those?

A "factory reset" in CubeIDE would be the equivalent of re-installing CubeIDE and starting in a new workspace. And you already tried re-installing.

Could you try to select debug with OpenOCD instead of ST-LINK GDB server instead? That could give us some more clues...