Showing results for 
Search instead for 
Did you mean: 

Cant do anything with the board

Associate III

I'm a new user working with a Nucleo F103RB board, and it suddenly stopped working. I can't program, debug, perform a chip erase, or access any sector. It began showing vFlash errors and is now stuck in a lockup stage. I've attempted to upload a different project with no success, and I've also tried a full chip erase, which failed. Additionally, it has entered read protection mode, preventing me from reprogramming the RDP using any other IDE or programmer utility.When i try to change the RDP in cube programmer it shows a error cant read data and the board disconnects itself. Is it a hardware problem?If so I could solder a new microcontroler in the nucleo.

Captura de tela 2024-05-13 143641.png



Accepted Solutions

You never show this


to you dont write if try slow down speed STLink from 4M for example to around 400k

Next choices is aplicaction note AN2606 switch MCU boot to DFU and use USB or USART , and yes last choice replace MCU.


View solution in original post


Did you short something out on the board?

Conductive metal surface? Connect to some other subsystem / voltage source?

Address here seems Wrong, and not in memory map.

Should be able mass-erase an F103 to clear RDP

Would suggest soldering a jumper between VDD and BTN0, and making BOOT0 HIGH so your code stops running and potentially breaking connectivity,

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

Right now, I can't erase anything with the ST utility or programmer because the application crashes or says the Nucleo got disconnected. The error occurred just after I uploaded code to the Nucleo.

I'll try the jumper solution tomorrow to see if anything changes. I'll also check for any shorted components.


Associate III

It doesn't seem to have changed anything. When I tried to program via ST Utility, it asked me if I wanted to disable readout protection, but it threw an error when trying to do so. Then the device disconnected itself, even with the jumper on Boot0 and VDD.Also couldnt do a full chip erase. 


Also when trying to disable read out protection



Could it be the power supply were cut while programming?.. but according to the ST-LINK utility (a deprecated tool) you can read the Flash content!

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.

But how? It says read data failed,even in the cube programmer.

Try to connect to the target under "Hardware reset".

To give better visibility on the answered topics, please click on "Accept as Solution" on the reply which solved your issue or answered your question.


Here is what happens in cube programmer,cant reprogram option bytes. Also core reset and software reset doesnt seem to change anything. St-link firmware is already at the latest.With or without the jumper boot to vdd doesnt seem to change anything .

Expand Read Out Protection and try change it to normal