Showing results for 
Search instead for 
Did you mean: 

STM32MP157D-DK1 monitor resolution problems


I have an STM32MP157D-DK1 development board and have built a buildroot image using the bootlin buildroot-external-st (st_stm32mp157d_dk1_demo_defconfig) external build tree. I have an Acubrite 12" 1080p touchscreen monitor that I am trying to get working at the monitor's native 1920x1080 resolution for use with a QT5 application but it is not working.

The monitor works fine but is limited to 1280x720 resolution. Modetest does not report anything higher than 1280x720:


root@stm32mp1:~# modetest -M stm
id	crtc	type	possible crtcs	possible clones	
31	38	DPI	0x00000001	0x00000001

id	encoder	status		name		size (mm)	modes	encoders
32	31	connected	HDMI-A-1       	250x140		5	31
	index name refresh (Hz) hdisp hss hse htot vdisp vss vse vtot
  #0 1280x720 60.00 1280 1390 1430 1650 720 725 730 750 74250 flags: phsync, pvsync; type: driver
  #1 1280x720 50.00 1280 1720 1760 1980 720 725 730 750 74250 flags: phsync, pvsync; type: driver
  #2 800x600 75.00 800 816 896 1056 600 601 604 625 49500 flags: phsync, pvsync; type: driver
  #3 720x576 50.00 720 732 796 864 576 581 586 625 27000 flags: nhsync, nvsync; type: driver
  #4 720x480 59.94 720 736 798 858 480 489 495 525 27000 flags: nhsync, nvsync; type: driver


If I use this monitor with Windows 10/11 or Ubuntu 22.04 on a desktop PC, 1080p is detected straight away. Same thing trying it on a Raspberry Pi running Raspbian (works straight away). 

I also tried it with the starter image provided by ST (SD card provided with the dev kit that boots openst linux) and it also only detected 1280x720p. 

I tried a few other 1080p monitors we have lying around the office and one of them worked (modetest showed a valid 1920 x 1080 resolution) and one of them didn't (modetest only showed 1280x720).

I'm not sure where to go from here. Any advice would be greatly appreciated.



Bump. Would appreciate any help.

ST Employee

HI @adrayic ,

Note that board support only up to 1080p30, not 1080p60, maybe your monitor does not support 1080p30.

Have you already look at this page : ?

Have you tried to flash latest Starter Package on SD card  (the one provided with the Board might be outdated) ?



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.