Showing results for 
Search instead for 
Did you mean: 

STM32mp157F DK2 burned

Associate II

First acquaintance with STM32mp157FDK2. A couple of weeks ago I bought two sets to try. In a week I figured out how to put together my image with Yocto. And today what was supposed to happen happened. I connected the KIT to the power supply with PD3. KIT is broke. The thermal camera shows strong heating. STPMIC1APQR short circuit STPMIC1APQR. burned out. Unsuccessful test STM32mp1.




I have not had such problems with any platform. This is not a charger, it is a power supply with PD 3.0. Now it is very difficult to find a good powerful USB-C source without support for PD 3.0.

I have this :


USB-A port never tries quick charge, 5V 3A output.

But if using USB-C -- USB-C , it will fast charge...need to be sure, if connect your phone also, it can deal with this.

If you feel a post has answered your question, please click "Accept as Solution".

Is this a warranty case or not? The documentation does not indicate that PD 3.0 cannot be used.

Sorry, no . 

I think , the user manual states it very clear :


You killed one board ? or both ?

Depends, where you did buy them, you could try...

telling something like : " it worked fine one week, then suddenly no more. With same setup, so i think, it was a some chip defective. "

-- Is up to you. You know, you killed it, because not reading the manual in detail. could try, if you think, that's ok.

>The documentation does not indicate that PD 3.0 cannot be used.

But also nothing about it CAN be used - right ?

If you feel a post has answered your question, please click "Accept as Solution".

>>>>But also nothing about it CAN be used - right ?


killed one board. My power supply provides 5V 3A. I've read the documentation. The documentation does not contain any warnings that the board does not support modern technologies with support for PD 3.0. Why then make a power input from the USB-C? is STM32mp1 god for a new product? Good question. I bought it from Digikey.

Ok, just (i would try... 🙂 ) .

And use a power supply , that only (!) can do 5V , 3A . As written in manual.

NOT guessing, it should be do this or that...

And i admit, using the USB-C is in some way seductive , to think, it works like an I-Phone and has high power SMPS inside. But think, this is not a product for the mass market, its for engineers and developers, so the producer can expect, they read, what it can do and what is not allowed. 


I just looked at ali :




USB-A to USB-C cannot do anything than 5V , afaik. So i would use something like this - or a big 5V supply, soldered to a USB-C cable.



If you feel a post has answered your question, please click "Accept as Solution".

i have 

Raspberry Pi - Netzteil, 5,1 V, 3,0 A, USB Type-C, EU-Stecker

This looks good - just check, it can do only 5V . NO fast charger...

Should be written on the charger...

Just a question: was the "killed" board working before , with this PD3 supply ?


If you feel a post has answered your question, please click "Accept as Solution".
ST Employee

HI @karu2003 

I'm sorry to see that you had hardware issue with your board.

The STM32MP157F-DK2 is working without issue with any USB Type-C charger which are USB certified.

As per USB-C and Power Delivery standard

  • charger should not provide any supply until CC lines are loaded
  • charger should always start with 5V supply until there is successful Power Delivery negotiation for higher voltage

The STM32MP157F-DK2 has no power delivery interface, so it is not possible to request something else than default 5V. That's the case of many USB-C powered products.

On STM32MP157F-DK2, the CC lines are only used to check that the charger pull-ups are defining 3A capability according to USB standard.

The STM32MP157F-DK2 has only ESD protection and no overvoltage protection on 5V input.


Your board could be defective, so you could ask for a replacement where you purchase it.

But I suspect the STPMIC1 burn is more related to a short circuit on its external components (usually inductors) which is quite easy with a development board (e.g. probe slip or metal stuff touching the board).

Ultimately, you could also try to replace the STPMIC1A (but need some experience in soldering and adequate tools)



In order to give better visibility on the answered topics, please click on 'Accept as Solution' on the reply which solved your issue or answered your question.