Showing results for 
Search instead for 
Did you mean: 

STM32WL error flashing with enabled LoRa middleware


Hello everyone,

I have an Olimex BB-SMT32WL that is based on a STM32WLE5CCU6. I use STM32CubeIDE and opened a new project for exactly the STM32WLE5CCU6.

Firmware Package Name and Version STM32Cube FW_WL V1.3.0

If I just configure like a GPIO Output to High it compiles and I can succesfully flash and debug it using STM32CubeIDE and openocd gdb running via terminal.

But as soon as I open the .ioc and simply enable SubGHZ and LoRaWAN things stop working, while it still compiles it won't flash anymore, throwing me this error:

(I also tried Arduino STM32duino but I'm getting the same error..)


Open On-Chip Debugger 0.12.0-00024-gc3ff39f8b (2023-06-26-16:51) []

Licensed under GNU GPL v2

For bug reports, read


adapter speed: 1000 kHz



Info : Listening on port 6666 for tcl connections

Info : Listening on port 4444 for telnet connections

Info : CMSIS-DAP: SWD supported

Info : CMSIS-DAP: FW Version = 1.0

Info : CMSIS-DAP: Interface Initialised (SWD)

Info : SWCLK/TCK = 1 SWDIO/TMS = 1 TDI = 0 TDO = 0 nTRST = 0 nRESET = 1

Info : CMSIS-DAP: Interface ready

Info : clock speed 4000 kHz

Info : SWD DPIDR 0x6ba02477

Info : [stm32wlx.cm4] Cortex-M4 r0p1 processor detected

Info : [stm32wlx.cm4] target has 6 breakpoints, 4 watchpoints

Info : starting gdb server for stm32wlx.cm4 on 3333

Info : Listening on port 3333 for gdb connections

Info : accepting 'gdb' connection on tcp/3333

Info : device idcode = 0x10016497 (STM32WLE/WL5x - Rev 'unknown' : 0x1001)

Info : RDP level 0 (0xAA)

Info : flash size = 256 KiB

Info : flash mode : single-bank

undefined debug reason 8 - target needs reset

[stm32wlx.cm4] halted due to debug-request, current mode: Thread

xPSR: 0x01000000 pc: 0x1fff2b6c msp: 0x20001508

Info : Padding image section 0 at 0x0800f894 with 4 bytes (bank write end alignment)

Info : SWD DPIDR 0x6ba02477

Error: Failed to write memory at 0x20009ff8

Error: block write failed

Error: error writing to flash at address 0x08000000 at offset 0x00000000

Warn : keep_alive() was not invoked in the 1000 ms timelimit. GDB alive packet not sent! (6795 ms). Workaround: increase "set remotetimeout" in GDB

[stm32wlx.cm4] halted due to debug-request, current mode: Thread

xPSR: 0x01000000 pc: 0x1fff2b6c msp: 0x20001508

shutdown command invoked

Info : dropped 'gdb' connection



Thanks in advance