cancel
Showing results for 
Search instead for 
Did you mean: 

FW-WBA v1.3.1: The code generated with this version doesn’t work.

KrassiNB
Associate

Hi, I upgraded CubeIDE from 1.14.1 to 1.15.1 and CubeMX from 6.10.0 to 6.11.1. After the upgrade I built my code, and everything worked fine but I changed some parameters in CubeMX and tried to regenerate the code. CubeMX asked for upgrade of FW_WBA from 1.3.0 to 1.3.1 and I did this upgrade also.

STM32 Board: STM32WBA52CG

With FW_WBA v1.3.1:

1. There is a linker error:

E:/DevTools/ST/STM32CubeIDE_1.15.1/STM32CubeIDE/plugins/com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.12.3.rel1.win32_1.0.100.202403111256/tools/bin/../lib/gcc/arm-none-eabi/12.3.1/../../../../arm-none-eabi/bin/ld.exe: warning: E:/DevTools/ST/STM32CubeIDE_1.15.1/STM32CubeIDE/plugins/com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.12.3.rel1.win32_1.0.100.202403111256/tools/bin/../lib/gcc/arm-none-eabi/12.3.1/thumb/v8-m.main+fp/hard/crtn.o: missing .note.GNU-stack section implies executable stack

E:/DevTools/ST/STM32CubeIDE_1.15.1/STM32CubeIDE/plugins/com.st.stm32cube.ide.mcu.externaltools.gnu-tools-for-stm32.12.3.rel1.win32_1.0.100.202403111256/tools/bin/../lib/gcc/arm-none-eabi/12.3.1/../../../../arm-none-eabi/bin/ld.exe: NOTE: This behavior is deprecated and will be removed in a future version of the linker.

2. Linker option -z noexecstack fixes the error.

3. The generated code crashes with Hard Fault in AMM_BackgroundProcess

HardFault_Handler() at stm32wbaxx_it.c:103 0x8007f34       

<signal handler called>() at 0xffffffbc              

_tx_thread_system_suspend() at tx_thread_system_suspend.c:85 0x80129a2             

_tx_semaphore_get() at tx_semaphore_get.c:214 0x8012284             

_txe_semaphore_get() at txe_semaphore_get.c:144 0x80139a4        

AMM_BackgroundProcess_Entry() at app_entry.c:549 0x8006cd2     

_tx_thread_shell_entry() at tx_thread_shell_entry.c:114 0x80126ac

<signal handler called>() at 0xffffffff

4. I've created a new project from scratch, and it has the same linker error and crashes the same way.

Tried with TreadX, FreeRTOS and Sequencer - no difference.

For me this version is unusable, and I have to go back to the previous ones.

1 REPLY 1
KrassiNB
Associate

Update:

I downgraded to the previous versions and there is no problem.

These are the versions that work:

STM32CubeMX 6.10.0

STM32CubeIDE 1.14.1

FW_WBA v1.2.0