Showing results for 
Search instead for 
Did you mean: 

[BLE] moving from stack 1.13 to 1.15 on FreeRtos example

Senior II


I changed my old files(1.13) to the new files from 'heart rate ble free rtos' (1.15)

Files: shci.h , app_conf.h

Cpu2 will not wake up. When I revert everything works.

What is causing this?

ST Employee

Hello @Community member​ 

We need more details on your case, in order to more understand the issue you are facing.

Which board are you using? which Cube package version?

Please share the steps to reproduce this issue, and more information about the error message.

This would be really helpful.


When your question is answered, please close this topic by clicking "Accept as Solution".
Associate II


I am facing the same problem.

I had my user board working orderly with 1.13 and after migrating to 1.15, it couldn't be connected at all, and the toolbox will popup a msg saying error occurred during connecting.

I tried to rebuild a new project using 1.15, and the ble can only be connected once, after disconnected, it couldn't be discovered any more.

I tried so many times to find out what is related to this issue and find out that once the FreeRtos is enabled (just with the default task, nothing else), this gonna happen.

any ideas why and how could I solve this?

I am highly appreciated with any feedback, thank you very much.