Showing results for 
Search instead for 
Did you mean: 

Installing ST Cube Crypto Library fails on STM32CubeMX 4.11.0

Steve H
Associate III
Posted on November 11, 2015 at 18:11

I'm trying to install the STM32Cube Cryptographic Library v3.0.0 on a fresh STM32CubMX install, version 4.11.0, under Windows 7. Installation fails with a message that ''This Package version is not managed on this version of STM32CubeMX.'' What's up with that? The most recent versions of these two items should logically be compatible...

The release notes in the zip file make no reference to any version limitation, nor do the online docs, and I've already tried it on an earlier STM32CubeMX installation with no success. One possibly-relevant fact is that when I unzip the downloaded .zip archive into my documents directory, I get a path-too-long error on some HTML files; however, when I unzip into C:/ the operation succeeds.

Has anyone succeeded in installing this library, or does someone know what's missing here?
Posted on November 11, 2015 at 18:55

The most recent versions of these two items should logically be compatible...

You're dealing with ST, not Spock..

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
ST Employee
Posted on November 12, 2015 at 09:42

Hi hersey.stephen.001,

The Cryptographic Library cannot be managed with CubeMX.

Only the STM32Cube packages containing the drivers for peripheral available in the STM32 microcontrollers are managed there. This is because STM32CubeMX generates the initialization code for selected peripherals that you configure in graphical interfaces.


To give better visibility on the answered topics, please click on Accept as Solution on the reply which solved your issue or answered your question.