Showing results for 
Search instead for 
Did you mean: 

Can't close Lab projects - File access rights

Andrew Neil
Evangelist III

During the workshop itself, I had some problems with some of the example files not having correct access rights to allow the workshop changes to be made.

We worked around that during the workshop.

Now I have just come back to the STM32Cube IDE; it started up with the last 2 workshop projects still open (as would be expected). But when I tried to close these projects, I got the following errors:


It seems that the whole workshop folder tree was installed with only 'Read' access for Users:


Giving 'Full Control' stopped the problems:

0693W000006Hb2WQAS.png0693W000006Hb2qQAC.pngHopefully this will be of help if anyone else is having the same problem.

But the question remains: why did the stuff get installed with these inappropriate settings?

This is on a standalone Win10-Pro.

Jocelyn RICARD
ST Employee

Hello Andrew,

After creating any directory you get this behavior. I mean : creator owner can modify whereas Users can only read.

So, I guess you didn't use the same user account between package installation and usage.

Is that the case?

Best regards


No, I used exactly the same account for installing and using - that's the strange part.

I've just downloaded the latest STM32CubeIDE, and installed it.

Now I'm getting the same again:

0693W000007BQ60QAG.pngAgain: downloaded, extracted, and installed all with the same login.

Jocelyn RICARD
ST Employee

Hello Andrew,

your issue seems related to a specific Windows policy.

I would suggest checking this with your IT

Best regards