Showing results for 
Search instead for 
Did you mean: 

STM32F746GDISCOVERY using system workbench form stm32 JTAG/SWD Writingto chip issue


Hello Guys,

I have code written in the past with firmware package STM32Cube_FW_F7_V1.11.0, and since the update to v1.15 it doesn't work anymore. My steps for coding this board were: Go to cube MX, choose the correct board, generate the default pinout and generated a SW4STM32 project and it worked for testing.

Sometime ago I remember having this same JTAG/SWD debugging problem, and just going to debug configuration->show generator options and changing it to SWD 4MHz used to work. Now it isn't working anymore.

I see a lot of users having this same problem, and lots and lots of solutions, from changing the usb port to a usb2.0 port, and changing .cfg file , or debbugging configurator to SWD worked. Most cases users use Keil or other paid solutions which I'm avoiding, to be able to use my board freely and they don't hide many of my board options or create abstraction layers on top of it.

Right now I'm able to run my board if I disable automated generation options and force my .cfgfile to use swd. But I don't think it is a good solution and I'm sure I lack knowledge about why this kind of problem is going on, and since there aretons of solutions which basically end up using working arounds, but I want to understand why ubemx is not generating code that is working with workbench.

Resuming this: after generating STM32f746GDisco board default project in CubeMX to work with System Worbench,it doesn't Run or Debug.

The erroris related to JTAG in some how:

Wrong device detected

 Open On-Chip Debugger 0.10.0+dev-00021-g524e8c8 (2019-04-12-08:48)

 Licensed under GNU GPL v2

 For bug reports, read

 srst_only separate srst_nogate srst_open_drain connect_assert_srst

 Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD

 adapter speed: 12000 kHz

 adapter_nsrst_delay: 100

 Info : clock speed 12000 kHz

 Info : STLINK v2.1 JTAG v34 API v2 M25 VID 0x0483 PID 0x374B

 Info : using stlink api v2

 Info : Target voltage: 3.210471

 Error: init mode failed (unable to connect to the target)

 in procedure 'program' 

 in procedure 'init' called at file "embedded:startup.tcl", line 495

 in procedure 'ocd_bouncer'

 ** OpenOCD init failed **

 shutdown command invoked

Is there any eclipse/system workbench config that I may be missing ?

Thanks for any help guys.