Showing results for 
Search instead for 
Did you mean: 

NUCLEO-F411RE will not work with External 3V3 Source.

Associate II
  • I am trying to evaluate the low-power capabilities of the STM32F411 using the Nucleo Dev Kit.
  • I have used a simple code provided in STM SDK to toggle LED 2 at 1 second interval.


  • LED will toggle when the board is powered by on-board USB, or 5V at VIN.
  • As a starting point for 3V3 external supply, I am using this (Image - Datasheet Page 22-Table 9)


  • At first I tried to de-solder the Solder Bridges as recommended, and apply a 3v3 at the VDD pins -> I get 3V3 at the MCU but the LEDs are not toggling.
  • I tried to cut off the Board, and Apply 3V3 at Vdd pins -> No LED Toggle.
  • After cutting the board and Applying 5V at VIN as I did earlier -> No LED Toggle.

I am open to any suggestions and recommendations.




What do you see, voltage wise, at the NRST pin, and those of the VCAP pin(s)

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..
Principal III

Check VDD at Jumper JP6. Check at the connector that BOOT0 is low and NRST high. You can re-connect the cut-off ST-LINK via PA13 PA14 and GND and check/debug/program your board via ST-LINK.




Read and check the schematics. Nucleo should have a tap point for mcu current excluding the rest. Make sure stlink power line is decoupled.

Hey Tesla,

- Voltage at NRST Pin = VDD(3.23V)

- Voltage at VCAP(C26) = 1.10V

- VCAP C25,C22 is DNP by Default. It is 0V at these Cap +ve Pads.


Hi KnarfB.

- VDD at Jumper JC6 is 3V3 (SB2 is Desoldered to isolate the LDO)

- BOOT0/R33 is 0V and Connected to GND. NRST is HIGH.

- The Board works as expected when its powered by 5V VIN, E5V or STLINK. As soon as its changed to 3V3 it stops working.

I would also like to mention that my colleague was able to independently verify this 3V3 issue. I believe he received the dev kit from the same production batch. He was not able to get anything of 3V3 working.

Thanks, Gurbir


I have isolated the MCU from ST-Link by Solder bridges and cutting the top part off. The LDO is also Isolated, I am still not able to get it working with 3v3. Thanks