Showing results for 
Search instead for 
Did you mean: 

LSE OSC32 not starting oscillation

Sylvain Kaempfer
Posted on December 16, 2016 at 14:27


I recently bought some stm32f303vct6 for a clock project. I first made a version for the stm32f3discovery board and my program worked, then I tried to program a microcontroller who isn�t on the discovery board everything work except that the LSE doesn�t start to oscillate. I tried to change my capacitor but nothing changed.

Can someone help me?

Best Regards


PS: I use CubeMX to generate the initialization code

Senior II
Posted on December 16, 2016 at 20:12




You should checkif the new LSE source (crystal/oscillator) is correct - > check the table.7 of application note

Second, the used project generated from the CubeMx is for the STM32F3-Disco hardware ; the workspace will include many HW dependencies you would check -> I advise you to regenerate another project using the .ioc file with selection you new board or simply the device.

-Walid F-

Posted on December 17, 2016 at 16:40

Hi Walid F

Thank you for answering. I'm sure that the new LSE source is correct. For the second part I’m not able to test it until Tuesday.

Best regards


Posted on December 20, 2016 at 13:59

The STM32 devices don't function properly with the 9pF and 12pF 32.768 KHz crystals that are quite common. You want one of the 6-7pF variety, and review the performance of the circuit with the components as built. The most common failures are taking a long time to start, or not starting, and frequency being off or unstable.

Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..