Showing results for 
Search instead for 
Did you mean: 

I am using the STM CubeIDE with a Nucleo L476RG dev board. When I first generated a project I was able to download it to the card and debug. then for some reason I started getting an error saying the arm-none-eabi-gdb.exe has stopped working.

Associate II

I am able to open an example project and debug that without issues. I have tried regenerating my project, generating a new project, and even reinstalling the tool and generating a new project, but I still get the same error on debugging. I can still debug the example project just fine, but the generated template project doesn't work. Any help is appreciated

Associate II

Just as suddenly that this stopped working for me it seems to have started again. I put a delay call in the while loop of main and it now no longer gives me the above error. I commented out the delay call and it still works???


I'm new to STM32 and trying to get the LED flash project to work but persistently get this same error message after the 'debugger connected'message in the console window. At the moment I am wondering whether this is worth while after years of PIC32MX's just working...

Associate III

I am also having the same problem with STM32CubeIDE on the Nucleo L476RG dev board that I programmed 6 months ago. I even re-downloaded and re-installed 1.5.1, but it still has the same problem with that one board. I was able to program a Nucleo-F446 board. Went back to the L476 and same problem. Did ST delete the L476 or something weird?