Showing results for 
Search instead for 
Did you mean: 

How do I get STM32F0 to show up under "Ports " in device manager?

Associate II

My STM32F0 won't show up under "Ports " in my device manager. It does, however, show up under "Universal Serial Bus Devices". I'm trying to print to a serial monitor. I've spent over 12 hours (low guess) trying to troubleshoot this issue. Here is what it looks like in my device manager.0693W00000KbNFGQA3.pngHere are some of the settings I've tried

0693W00000KbNGBQA3.pngI did also try using RCC as Crystal/Ceramic Resonator


0693W00000KbNGGQA3.png0693W00000KbNGVQA3.png0693W00000KbNDLQA3.pngWhat do I need to do so I can get my device to show up as COM 4 or COM 6 or some other COM channel?

Thank you for taking time to look at my question! 🙂


The "STM32 STLink" device showing up is the ST-Link debugger chip, not the STM32F0 chip.

What hardware are you working on and how exactly is it hooked up? In addition to getting the USB driver firmware working, you'll need to connect to the chip directly through the USB pins.

If you feel a post has answered your question, please click "Accept as Solution".
Associate II

Here's my setup. Pretty basic, just trying to get this part to work before moving on.

0693W00000KbVGPQA3.jpgDo I need additional hardware to make this work? Do I need to connect to the other micro-usb slot? (actually just tried that and it didn't seem to work when I plugged it in).

Are the setting I chose the right ones?


The "USB USER" port is connected to the target chip, so yes, you need to use that one. The "USB ST-LINK" is connected to the ST-Link chip.

Can probably get this to work on that board with minimal changes:

If you feel a post has answered your question, please click "Accept as Solution".
Associate II

Sweet, thanks 😊 I'll try out that code. I may be back after giving it my best shot if it doesn't work.

Associate II

Hi @TDK​ !

Alright so yes it's been a while since I've looked at this problem again because it was frustrating me. I tried your suggestion once before that I needed to use the usb user connection, but it hadn't worked. Today I again just tried to enable the USB as Device (FS), and then the USB_DEVICE as Communication class VCP, and then connected to the usb user connection on the board and it worked. I remember doing that before, but now it's April so it makes sense that it works now, you know how it goes 😂

FYI, if anyone needs clarification on what I did because they're having the same problem I will elaborate on what I did.

Hi @CR72​ I�? am having a similar issue with a different type of STM32F0. We cannot get the VCOM port to receive data through the micro usb connected to the board. We have tried using an older Operating system to be compatible with ST's drivers but haven't had any luck. I�? was wondering if you could elaborate on what you did and what specs you are using?

The STM32 F0 Discovery board has TWO MINI USB connectors, one connected to the ST-LINK/V2, that doesn't support a serial port, that's a later ST-LINK/V2-1 design feature.

The USER USB connects to the STM32F0 part, that need you to build a USB CDC/VCP DEVICE, depends on the F0 to have a viable USB port and appropriate software load.

Look at porting the example


Tips, Buy me a coffee, or three.. PayPal Venmo
Up vote any posts that you find helpful, it shows what's working..

I�? am working with the STM32F051R8T6, it only has one MINI USB connector which is the ST-LINK/V2. You are saying that we cannot use this to send data to VCOM? We have thought about switching to the external ST-LINK/V2 Debugger and using an FTDI. Thanks for the quick response

Pavel A.
Evangelist III

> We have thought about switching to the external ST-LINK/V2 Debugger and using an FTDI.

You can just hook a TTL to USB adapter (few models on sale, cheaper than FTDI) to some STM32F0 UART. Connect both the ST-LINK cable and the adapter to a hub, so there's only one cable to plug into your PC.